@secured 不起作用

小明123213123 发布于 2014/04/16 17:12
阅读 1K+
收藏 0

这是我的controller

@Controller
public class Test {
@Secured("ROLE_ADMIN")
@RequestMapping(value="/t1")
public void test1(){
System.out.println("222");
}
}


security.mxl

 
    <global-method-security secured-annotations="enabled" jsr250-annotations="enabled"
    ></global-method-security>
    
    
     <http auto-config="true" use-expressions="true" access-denied-page="/auth/denied" >
      <intercept-url pattern="/auth/login" access="permitAll"/>  
        <intercept-url pattern="/main/admin" access="hasRole('ROLE_ADMIN')"/>  
        <intercept-url pattern="/main/common" access="hasRole('ROLE_USER')"/>  
        <form-login  
                login-page="/auth/login"   
                authentication-failure-url="/auth/login?error=true"   
                default-target-url="/main/common"/>  
        <logout   
                invalidate-session="true"   
                logout-success-url="/auth/login"   
                logout-url="/auth/logout"/>  
     </http>
    
    用@secured标注 怎么访问都不起作用,同事的就行,不知道为啥,大家帮忙看看吧
     <authentication-manager>  
            <authentication-provider user-service-ref="customUserDetailsService">  
                   <!--  <password-encoder ref="passwordEncoder"/>   -->
            </authentication-provider>  
    </authentication-manager>  


加载中
1
tianlangxing
tianlangxing
<security:global-method-security pre-post-annotations="enabled" /> 需要放在*-servlet.xml中,不能放在*-security.xml中
l
loslaputa
回复 @MaxCrazy : +1 找了半天的错结果使这里的问题= =
MaxCrazy
MaxCrazy
感谢大神,困扰2天问题,无意发现你的答案试了一下,果然运行成功
返回顶部
顶部