有大神知道 Jquery easyui 在IE10以下的版本中没有样式是为什么吗?

嘎嘣豆 发布于 2014/05/24 10:37
阅读 2K+
收藏 0

第一个问题:我用的是目前easyui官网上最新的版本,我用IE10没问题,但是用兼容模式或IE9、8、7没有样式了。在F12开发者工具里,我发现当默认IE10浏览器下,文档模式默认为标准(应该是IE10标准),但我选择IE9或以下版本时,默认文档模式都是IE5 Quirks,控制台也会出现错误。但是我在试淘宝的时候发现他的 默认文档模式随着选择IE版本而改变为对应版本的,比如我在淘宝的页面下选择IE9,他的默认文档模式也变为IE9的,但在我的页面选择IE9,默认文档模式 则是IE5 Quirks。这是什么原因?

第二个问题:最新版的easyui在文档模式为IE9版本及以上显示正常,以下就无样式(与浏览器模式无关)。最新版本的easyui可能不兼容IE9以下的文档模式,与浏览器模式无关。但是奇怪的是easyui官网的demo缺不受任何影响,很正常。这是什么原因?是否有大神试过?

加载中
0
Big_BoBo
Big_BoBo
官网的demo引入的jquery是1.x版本的,最新版的easyui自带的是2.x版本的jquery,不支持IE9以下,你可以自己替换成1.X版本
嘎嘣豆
嘎嘣豆
大神啊,呵呵,我上午也试了试了,是jquery.mini.js的问题,我已经换成了1.4的了,别的文档模式都可以了,但是在文档模式IE5 Quirks下,一些图标显示不出来,要是用鼠标划过就显示出了,不知道低版本的IE浏览器,是默认哪种文档模式?因为我的IE10默认是Quirks,IE9、8、7默认是IE5 Quirks
0
穆英智
穆英智
再遇到这样的事,直接将演示网站引用的js,css下载下来用用
返回顶部
顶部