运行maven插件的时候如何指定版本?

lmqian 发布于 2016/09/23 14:49
阅读 1K+
收藏 0

mvn版本号3.2.5。在使用mvn install:install-file的时候发现默认使用的是maven-isntall-plugin-2.4的版本,但是这个版本插件在生成.pom文件的时候有点不好,看过源码2.5的版本已经解决了这个问题。但是每次运行这个插件的时候始终是2.4版本。检查过超级POM,里面没有给这个插件指定版本,中央仓库中的元数据中指定的版本是2.5.2了,这是为什么?

加载中
0
SuperShaunChyxion
SuperShaunChyxion
<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-install-plugin</artifactId>
        </plugin>
    </plugins>
    <pluginManagement>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-install-plugin</artifactId>
                <version>2.5.2</version>
            </plugin>
        </plugins>
    </pluginManagement>
</build>

记得给最佳答案,

lmqian
lmqian
回复 @SuperShaunChyxion : 我还是没有找到为什么默认成2.4版本的,不过我通过修改超级POM文件实现了我想达到的效果。谢谢你了~
SuperShaunChyxion
SuperShaunChyxion
回复 @lmqian : 看看这个文档:https://maven.apache.org/plugins/maven-install-plugin/install-file-mojo.html,install-plugin版本是Maven默认指定的。
SuperShaunChyxion
SuperShaunChyxion
回复 @lmqian : 配置在pom.xml里面,如果是第三方的jar包没试过,也许你可以直接复制到到repository目录下。
lmqian
lmqian
谢谢你的回答 1、通过这个命令将第三方jar包放入本地仓库,你发的这段代码配置到什么地方? 2、是什么地方控制了默认使用2.4版本呢?
返回顶部
顶部