Relative ID is not allowed in global require: ./echarts/src/util/mapData/params

只有一点点 发布于 2014/04/28 13:52
阅读 4K+
收藏 0

@Kener-林峰

// 自定义扩展图表类型:mapType = HK

require('./echarts/src/util/mapData/params').params.GZ = {
    getGeoJson: function(callback) {
        $.getJSON('./js/geoJson/GZ_geo.json',callback);
    }
},
option = {
    title : {
        text : '香港18区人口密度 (2011)',
        subtext: '人口密度数据来自Wikipedia',
        sublink: 'http://zh.wikipedia.org/wiki/%E9%A6%99%E6%B8%AF%E8%A1%8C%E6%94%BF%E5%8D%80%E5%8A%83#cite_note-12'
    },
    tooltip : {
        trigger: 'item',

为什么老是报

Error: [REQUIRE_FATAL]Relative ID is not allowed in global require: ./echarts/src/util/mapData/params
都两天了,头都大了,求解决,这个是扩展的贵州地图

加载中
0
Kener-林峰
Kener-林峰

require('./echarts/src/util/mapData/params')!!!

require('echarts/src/util/mapData/params')

路径啊!!模块化不熟悉就用标签式引入吧,直接读命名空间就好 echarts.util.mapData.params

Kener-林峰
Kener-林峰
回复 @ma_sk : 有点就是相对路径寻找,没点就会模块寻找
ma_sk
ma_sk
为什么不能有./能说详细一点么?
0
只有一点点
只有一点点


我引入了<script src="js/echarts-plain.js"></script>
   <script src="js/echarts-plain-map.js"></script>

还是报错

TypeError: C[M.replace(...)] is undefined

@Kener-林峰


0
ViviRan
ViviRan
@ 只有一点点 请问您解决这个问题了么?我用这个示例也是各种显示不出来,求教
只有一点点
只有一点点
谷歌也是支持的。我这里是显示的,不知道你什么具体问题
ViviRan
ViviRan
@只有一点点 恩,也许是我引用的有问题,因为chrome出不来,所以问问有没有让chrome显示的方法呢0.0?
只有一点点
只有一点点
<script src="js/echarts-plain-map.js"></script> 我的解决了,我引用的这个地图插件,你是地图?
返回顶部
顶部