自己编译的QT4.6.3可以用,为什么QT4.7.1会出现段错误?

tom_riddle 发布于 2014/02/16 09:00
阅读 252
收藏 0
Qt
 

我使用的是友善之臂mini2440的开发板,移植qte时自己编译的QT4.6.3移植到开发板可以运行(友善之臂给的文件系统里就是QT4.6.3),但是又自己编译了QT4.7.1,移植到开发板上时却出现segmentation fault。我想问下是不是文件系统里需要配置什么?/etc/profile里已经配置如下:

export TSLIB_ROOT=/usr/local/tslib

export TSLIB_TSDEVICE=/dev/event0

export TSLIB_FBDEVICE=/dev/fb0

export TSLIB_CALIBFILE=/etc/pointerrcal

export TSLIB_CONFFILE=$TSLIB_ROOT/etc/ts.conf

export TSLIB_PLUGINDIR=$TSLIB_ROOT/lib/ts

export TSLIB_CONSOLEDEVICE=none

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$TSLIB_ROOT/lib

QTDIR=/usr/local/qt-arm-4.7.1

export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH

export LD_LIBRARY_FILE=/etc/pointercal

export QWS_MOUSE_PROTO=Tslib:/dev/event0

export set QT_QWS_FONTDIR=$QTDIR/lib/fonts

我的疑问是自己编译的QT4.6.3可以用,为什么QT4.7.1会出现段错误?是不是还需要在文件系统里修改什么配置??交叉编译器为arm-linux-gcc 4.3.2

 

加载中
返回顶部
顶部