编译PHP出现 configure: WARNING: unrecognized options: --enable-fastcgi原因

juhenj 发布于 2014/06/02 20:15
阅读 48K+
收藏 2

解读下一代网络:算力网络正从理想照进现实!>>>

./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --with-mysql=/usr/local/mysql/ --with-libxml-dir=/usr/local/libxml2/ --with-png-dir=/usr/local/libpng/ --with-jpeg-dir=/usr/local/jpeg9/ --with-freetype-dir=/usr/local/freetype/ --with-gd=/usr/local/gd2/ --with-mcrypt=/usr/local/libmcrypt/ --with-mysqli=/usr/local/mysql/bin/mysql_config --enable-soap --enable-mbstring=all --enable-sockets --enable-fpm --enable-fastcgi

最后的结果出现一个configure: WARNING: unrecognized options: --enable-fastcgi

这个影响我后面的编译么?



加载中
1
Helloall
Helloall

这个一般要按需求而定,你别照着网上抄, --enable-fastcgi参数已经去除了,不再需要添加该参数,默认开启。

juhenj
juhenj
回复 @dkrhxc : 感谢感谢感谢
Helloall
Helloall
回复 @放弃_250 : 如果安装apache就不需要fpm,如果你安装的是nginx就需要。。
juhenj
juhenj
回复 @放弃_250 : 非常感谢,我再去试试。我会努力滴
Helloall
Helloall
回复 @放弃_250 : 是的,别怀疑。
juhenj
juhenj
--enable-fpm 就留有这个就可以了么?
0
南湖船老大
南湖船老大

又瞎抄网上的东西了吧。。。不懂C,不懂make,不看手册,就不要编译安装。

Fastcgi is the preferred SAPI to connect PHP and Lighttpd. Fastcgi is automagically enabled in php-cgi in PHP 5.3, but for older versions configure PHP with --enable-fastcgi.
PHP的源码里安装文档INSTALL里明明白白写着这句话。不去看文档,这样的编译安装有什么用?
juhenj
juhenj
我感觉不懂英语就不要搞变成了
0
mark35
mark35
新版php不支持这个选项,默认就开启了
0
月影又无痕
月影又无痕
这个参数,一看就是从网上抄来的:

1. 竟然要使用源码自己编译扩展包?jpeg, png这些yum源已经自带,何苦要自己再编译?
2.没有使用mysqlnd驱动
3.竟然没有PDO支持

juhenj
juhenj
我能怎么办,不懂英语没人带,我能怎么办,不看网上的怎么搞
返回顶部
顶部