rabbitmq erlang安装问题

OLESHI 发布于 2018/03/12 16:48
阅读 3K+
收藏 0

如图所示erlang安装的是20.2 ,然后安装rabbitmq-server-3.7.4-1.el6.noarch.rpm

一直提示erlang >= 19.3 is needed ...

求解为何呢?

 

加载中
0
a
agong

引用来自“agong”的评论

问题解决了吗? 我 遇到相同问题, 我下的是20.3的erlang

我解决了,要从这里下载:https://bintray.com/rabbitmq/rpm/erlang/20.3-1

不要从这里下载:https://www.erlang-solutions.com/resources/download.html

 

O
OLESHI
https://bintray.com/rabbitmq/rpm/erlang/20.3-1,请问你是怎么了解到这个地址的?
O
OLESHI
我没有解决,,,但是貌似没有影响,不影响使用。。。
0
leeyi
leeyi

rabbitmq 是基于erlang语言开发的,这个版本的rabbitmq-server-3.7.4-1.el6.noarch.rpm 就需要erlang版本  >= 19.3, 这个还要解释原因吗? 你先把erlang升级到  >= 19.3 的版本,问题不就解决了吗?这个有什么难于理解的呢?

leeyi
leeyi
回复 @OLESHI : 哦哦哦,你安装最新稳定版的erlang试一试呢,要不就重新下载一个rabbitmq包
O
OLESHI
我安装的20.2 不符合 >=19.3?
0
混乱羽翼
混乱羽翼

直接docker启动吧,美滋滋

0
a
agong

问题解决了吗? 我 遇到相同问题, 我下的是20.3的erlang

0
慢跑慢跑

请问你怎么解决的,能否分享下??

慢跑慢跑
回复 @OLESHI : 我试了,还是 erlang >= 19.3 ,最后没办法 我直接下载Generic UNIX binary这个了=直接用了
O
OLESHI
https://bintray.com/rabbitmq/rpm/erlang/20.3-1这个地址下载的就可以了
O
OLESHI
小哥这不是有答案了吗
返回顶部
顶部