bundle install在Using jquery-rails 3.0.4报错

第7段材料 发布于 2014/09/09 17:52
阅读 639
收藏 1
Using jquery-rails 3.0.4


Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.


        /usr/bin/ruby1.9.1 extconf.rb 
creating Makefile
sh: 1: patch: not found
sh: 1: patch: not found
sh: 1: patch: not found
sh: 1: patch: not found
Compiling v8 for ia32
Using python 2.7.3
Unable to find a compiler officially supported by v8.
It is recommended to use GCC v4.4 or higher
Using compiler: g++
Unable to find a compiler officially supported by v8.
It is recommended to use GCC v4.4 or higher
make[1]: g++: Command not found
make[1]: *** [/var/lib/gems/1.9.1/gems/libv8-3.16.14.3/vendor/v8/out/ia32.release/obj.target/preparser_lib/src/allocation.o] Error 127
make: *** [ia32.release] Error 2
/var/lib/gems/1.9.1/gems/libv8-3.16.14.3/ext/libv8/location.rb:36:in `block in verify_installation!': libv8 did not install properly, expected binary v8 archive '/var/lib/gems/1.9.1/gems/libv8-3.16.14.3/vendor/v8/out/ia32.release/obj.target/tools/gyp/libv8_base.a'to exist, but it was not found (Libv8::Location::Vendor::ArchiveNotFound)
from /var/lib/gems/1.9.1/gems/libv8-3.16.14.3/ext/libv8/location.rb:35:in `each'
from /var/lib/gems/1.9.1/gems/libv8-3.16.14.3/ext/libv8/location.rb:35:in `verify_installation!'
from /var/lib/gems/1.9.1/gems/libv8-3.16.14.3/ext/libv8/location.rb:26:in `install!'
from extconf.rb:7:in `<main>'
GYP_GENERATORS=make \
build/gyp/gyp --generator-output="out" build/all.gyp \
             -Ibuild/standalone.gypi --depth=. \
             -Dv8_target_arch=ia32 \
             -S.ia32  -Dv8_enable_backtrace=1 -Dv8_can_use_vfp2_instructions=true -Darm_fpu=vfpv2 -Dv8_can_use_vfp3_instructions=true -Darm_fpu=vfpv3
make[1]: Entering directory `/var/lib/gems/1.9.1/gems/libv8-3.16.14.3/vendor/v8/out'
  CXX(target) /var/lib/gems/1.9.1/gems/libv8-3.16.14.3/vendor/v8/out/ia32.release/obj.target/preparser_lib/src/allocation.o
make[1]: Leaving directory `/var/lib/gems/1.9.1/gems/libv8-3.16.14.3/vendor/v8/out'




Gem files will remain installed in /var/lib/gems/1.9.1/gems/libv8-3.16.14.3 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/libv8-3.16.14.3/ext/libv8/gem_make.out
An error occurred while installing libv8 (3.16.14.3), and Bundler cannot
continue.

Make sure that `gem install libv8 -v '3.16.14.3'` succeeds before bundling.


加载中
0
fxhover
fxhover

gem install libv8 -v '3.16.14.3',安装这个之前系统需要先安装libv8这个软件包

安装成功之后再bundle install试试

返回顶部
顶部