debian 安装软件vim 出现 下列软件包有未满足的依赖关系

kseyxf 发布于 2013/12/16 12:57
阅读 2K+
收藏 0
Vim
apt-get install vim 出现 

下列软件包有未满足的依赖关系:
 vim : 依赖: vim-common (= 2:7.2.445+hg~cb94c42c0e1a-1) 但是 2:7.3.547-7 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

请问如何解决?

sources.list 是这样的

# 

# deb cdrom:[Debian GNU/Linux 7.2.0 _Wheezy_ - Official amd64 DVD Binary-1 20131012-14:05]/ wheezy contrib main

#deb cdrom:[Debian GNU/Linux 7.2.0 _Wheezy_ - Official amd64 DVD Binary-1 20131012-14:05]/ wheezy contrib main

deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ wheezy-updates main contrib
# deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib


deb http://mirrors.163.com/debian squeeze main non-free contrib
deb http://mirrors.163.com/debian squeeze-proposed-updates main contrib non-free
deb-src http://mirrors.163.com/debian squeeze main non-free contrib
deb-src http://mirrors.163.com/debian squeeze-proposed-updates main contrib non-free

deb http://mirrors.163.com/debian-security squeeze/updates main contrib non-free 
deb-src http://mirrors.163.com/debian-security squeeze/updates main contrib non-free



加载中
0
c
c2547959
你在debian 7里面用debian 6的源不是给自己找罪受么, 把squeeze的都替换成wheezy
0
k
kseyxf

引用来自“c2547959”的答案

你在debian 7里面用debian 6的源不是给自己找罪受么, 把squeeze的都替换成wheezy
谢谢问题已经解决
0
孤单时会想你
孤单时会想你

当提示缺少依赖是 执行

sudo apt-get -f install



-f  Attempt to correct a system with broken dependencies in place

自动适配缺少的依赖包

返回顶部
顶部