python3 打包失败了 /root/anaconda3/bin/pyinstaller -F -w -i manage.ico t.py -F

tengX前端工程师 发布于 04/18 13:34
阅读 374
收藏 0

173264 INFO: Including run-time hook 'pyi_rth_mplconfig.py'
173266 INFO: Including run-time hook 'pyi_rth_mpldata.py'
173370 INFO: Looking for dynamic libraries
ldd: warning: you do not have execution permission for `/root/anaconda3/lib/python3.7/site-packages/_pylief.cpython-37m-x86_64-linux-gnu.so'
ldd: warning: you do not have execution permission for `/root/anaconda3/plugins/imageformats/../../lib/libgcc_s.so.1'
178461 INFO: Looking for eggs
178461 INFO: Python library not in binary dependencies. Doing additional searching...
Traceback (most recent call last):
  File "/root/anaconda3/bin/pyinstaller", line 10, in <module>
    sys.exit(run())
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/__main__.py", line 111, in run
    run_build(pyi_config, spec_file, **vars(args))
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/__main__.py", line 63, in run_build
    PyInstaller.building.build_main.main(pyi_config, spec_file, **kwargs)
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/build_main.py", line 838, in main
    build(specfile, kw.get('distpath'), kw.get('workpath'), kw.get('clean_build'))
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/build_main.py", line 784, in build
    exec(text, spec_namespace)
  File "<string>", line 17, in <module>
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/build_main.py", line 241, in __init__
    self.__postinit__()
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/datastruct.py", line 158, in __postinit__
    self.assemble()
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/build_main.py", line 573, in assemble
    self._check_python_library(self.binaries)
  File "/root/anaconda3/lib/python3.7/site-packages/PyInstaller/building/build_main.py", line 676, in _check_python_library
    raise IOError(msg)
OSError: Python library not found: libpython3.7.so.1.0, libpython3.7mu.so.1.0, libpython3.7m.so.1.0
This would mean your Python installation doesn't come with proper library files.
This usually happens by missing development package, or unsuitable build parameters of Python installation.

* On Debian/Ubuntu, you would need to install Python development packages
  * apt-get install python3-dev
  * apt-get install python-dev
* If you're building Python by yourself, please rebuild your Python with `--enable-shared` (or, `--enable-framework` on Darwin)
 

加载中
返回顶部
顶部