LAMP环境搭建遇到了一些问题

Scchary 发布于 2014/08/19 17:47
阅读 7K+
收藏 1

@Saki 你好,想跟你请教个问题:我安装的是,期间碰到各种错误,最后一个错误不知道怎么解决,在configure=》apache的时候,出现这样的错误

error: ... Error, zlib was missing or unusable 



我就查了下,我电脑上是安装这个软件的,但是我想可能是apache的版本太高不能识别(因为之前别的软件也出现过这样的情况,我自己装个新版本的就ok了),所以我就自己安装zlib,但是找不到你说的哪个在安装zlib之前要安装的apt-get install zlib1g-dev ,这个指令没用(我用的red hat enterprise linux),就直接安装,就出现了这样的错误,

Compiler error reporting is too harsh for ./configure (perhaps remove -Werror).

** ./configure aborting.

想问下,这个问题怎么解决?apache版本是2.4.10

加载中
0
eechen
eechen
Linux上编译软件一般都是先安装依赖的运行库和头文件。
Ubuntu、Debian上构建Nginx、Apache、PHP可以参考这篇文章:
http://my.oschina.net/eechen/blog/298027
Scchary
Scchary
3Q
0
Saki
Saki

试试这个

  1. yum install zlib-devel
Ubuntu 跟 redhat 稍微有点点区别

Saki
Saki
回复 @Scchary : 红帽跟ubuntu安装方式有些区别,你按照我写的安装可能会出现很多问题,你可以百度下红帽LAMP的搭建,或者centos相关的资料
Scchary
Scchary
最郁闷的是,明明我系统已经装了这个软件了,还是要我重新安装一遍,你说的那几个软件全都重新安装了一遍
Scchary
Scchary
我试试,哎,真倒霉,早上一来,redhat系统进不去了,又要重新装redhat
0
Helloall
Helloall

缺乏zlib咯,很简单下载安装即可

http://zlib.net/zlib-1.2.8.tar.gz

Helloall
Helloall
回复 @Scchary : vim打开你的配置文件 You dir/zlib/configure ,把-Wall都去掉。然后重新编译安装。
Scchary
Scchary
回复 @_Obama : 我这这样configure的 ./configure \ --prefix=/usr/local/zlib 没有加那个属性
Helloall
Helloall
回复 @Scchary : 不要添加该参数--Werror,这样gcc会把警告当作错误处理,所以你无法编译。
Scchary
Scchary
回复 @_Obama : configure那个zlib的时候出现这个错误Compiler error reporting is too harsh for ./configure (perhaps remove -Werror). ** ./configure aborting.
Helloall
Helloall
回复 @Scchary : ./configure --prefix=/usr/local/zlib && make && make install 这样就ok了。然后apache2安装记得包含该路径 ./configure --prefix=/you install path/ --with-zlib=/usr/local/zlib
下一页
返回顶部
顶部