Ubuntu14.04安装build-essential失败,包依赖问题如何解决?

西安鲲之鹏 发布于 2016/06/15 16:40
阅读 2K+
收藏 1
qi@ubuntu :/var/cache/apt$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:


下列软件包有未满足的依赖关系:
 build-essential : 依赖: libc6-dev 但是它将不会被安装 或
                           libc-dev
                   依赖: gcc (>= 4:4.4.3) 但是它将不会被安装
                   依赖: g++ (>= 4:4.4.3) 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。


确定源没有问题,试过sudo apt-get update; sudo aptitude install build-essential,还是一样的提示。

加载中
0
西安鲲之鹏
西安鲲之鹏

问题解决了:

sudo aptitude update 

sudo aptitude install build-essential


第一次感受到了aptitude和apt-get的区别!

网上有人说“aptitude 与 apt-get 一样,是 Debian 及其衍生系统中功能极其强大的包管理工具。与 apt-get 不同的是,aptitude 在处理依赖问题上更佳一些。举例来说,aptitude 在删除一个包时,会同时删除本身所依赖的包。这样,系统中不会残留无用的包,整个系统更为干净。以下是笔者总结的一些常用 aptitude 命令,仅供参考。”

返回顶部
顶部