php5.2.17分别和Mysql5.1.73及mysql5.5搭配性能比较

女码农 发布于 2014/11/20 22:17
阅读 2K+
收藏 0
环境:
系统支持:CentOS 6.5 64位linux系统
内存:≥512M
 
安装了以下:
1、Apache 2.2.15
2、MySQL 5.X
3、PHP 5.2.17
4、phpmyadmin 4.1.4
5、ZendOptimizer 3.3.9
6、curl 7.19.7
7、vsftp
 
Mysql5.x版本选用Mysql5.1.73和Mysql5.5, php5.2.17分别和这两者搭配,性能分别如何?
 
Linux+Apache+Mysql+PHP是一组常用来搭建动态网站或者服务器的开源软件,本身都是各自独立的程序,但是因为常被放在一起使用,拥有了越来越高的兼容度. 就是想了解,LAMP组合到现在,各独立程序不同版本搭配,是不是各自最稳定的版本组合在一起,拥有的稳定性就是越大,性能越大,还是有可能不同的版本之间搭配,所拥有的稳定性和兼容性不一样? 相信在这方面有多年运维经验的肯定有答案.
 
加载中
0
eechen
eechen
PHP以apache2handler这个形式的SAPI与Apache Prefork进程化MPM运行是比较稳定.从5.4开始,PHP内建支持 mysqlnd,mysqlnd并不像libmysql那样作为通用库,它是专门为PHP而写的一个库. ZendOPcache已经开源,以PECL共享库在内存缓存PHP中间码,提升PHP性能.

Apache2.4(Prefork MPM) + PHP5.4(ZendOPcache) + MySQL5.5 应该是稳定而且快速的组合。
http://my.oschina.net/eechen/blog/298027
女码农
女码农
但目前如果网站只支持php5.2,apache和mysql各选用哪一个版本才是最稳定而快速的组合? 在网上查到,mysql5.x都稳定,可为何还有这么多的人从5.1升级到5.5呢?
0
淡定的wo
淡定的wo
mysql选择5.0.x或者5.1.x最新的子版本。
女码农
女码农
回复 @淡定的wo : mysql5.5好像不少人用过,也没有什么问题吧.现在是想了解mysql5.1.73和mysql5.5各如何.
淡定的wo
淡定的wo
回复 @女码农 : php5.2官方很早以前已经停止更新和维护。相应的php5.2也就没有对新版mysql进行任何优化。会出现莫名的问题。我已经被这个坑过N次。切忌切忌啊!
女码农
女码农
为何不推荐mysql5.5?
0
Cral
Cral

史上最难PHPer笔试题,40分就能月薪过万!

http://www.sijiaomao.com/exam.htm

Tuesday
Tuesday
恶心的功能....
0
牧沐
牧沐
还是选高版本吧 阿里云现在都推荐5.5 5.6版的mysql了 说5.1版不再支持更新
牧沐
牧沐
回复 @女码农 : 了解了 ,本来我还犹豫阿里云要不要听他们的建议升级mysql,现在看 还是以稳定为主
女码农
女码农
阿里云云服务器ECS centOS 6.5 64位系统自带的mysql最高版本为5.1.73版本,阿里云是这样解释的:5.5和5.6是阿里云官方RDS的提供服务版本,因为对镜像并没有强制要求,一定要是哪些版本的应用才可以上线,所以这些环境是第三方那里经过测试的可以稳定运行的环境,在生产环境中,追求的是系统的稳定性,所以第三方处于这方面的考虑使用了这个版本。
女码农
女码农
阿里云云服务器ECS centOS 6.5 64位系统自带的mysql最高版本为5.1.73版本
返回顶部
顶部