linux下的声卡驱动编译时出现“字段‘latency_pm_qos_req’的类型不完全”问题?

追风A沉默 发布于 2013/10/15 10:11
阅读 979
收藏 0
在make   alsa-driver-1.0.25 时出现
In file included from /usr/src/alsa1/alsa-driver-1.0.25/acore/pcm.c:30:0:
/usr/src/alsa1/alsa-driver-1.0.25/include/sound/pcm.h:435:24: 错误:字段‘latency_pm_qos_req’的类型不完全
make[3]: *** [/usr/src/alsa1/alsa-driver-1.0.25/acore/pcm.o] 错误 1
make[2]: *** [/usr/src/alsa1/alsa-driver-1.0.25/acore] 错误 2
make[1]: *** [_module_/usr/src/alsa1/alsa-driver-1.0.25] 错误 2
make[1]: 离开目录“/usr/src/kernels/2.6.35.6-45.fc14.i686”
make: *** [compile] 错误 2
怎么会事?求大神解救?谢谢

以下是问题补充:

@追风A沉默:电脑是联想g480的,声卡应该是英特尔 Panther Point PCH - High Definition Audio Controller [C1] 装的时Fedora14,求大神 (2013/10/15 10:18)
加载中
0
算法与编程之美
算法与编程之美
使用新版的内核试试
追风A沉默
追风A沉默
回复 @justin_cn : 首先再次表示感谢,已经看过driver代码了,可能因为我还是个菜鸟,所以找不出问题……
算法与编程之美
算法与编程之美
回复 @追风A沉默 : 推荐做法的还是去分析driver代码看看问题到底出现在什么地方,换内核也许能解决该问题,之前也有很多人遇到过这个问题。
追风A沉默
追风A沉默
谢谢,我尽量试试吧……不过还是非常感谢你……
返回顶部
顶部