急,急,急,php apache 域名绑定

玉良 发布于 2013/07/05 13:27
阅读 563
收藏 1
PHP

我有两个wordpress 项目 a1和a2

用的亚马逊ec2 ,项目路径是 /opt/www/a1 ,/opt/www/a2

当只有a1 一个项目时,我这样配置的

<VirtualHost *:80>

ServerName www.a1.com

DocumentRoot "/opt/www/a1"
</VirtualHost>

然后,通过 www.a1.com 可以正常访问


当有两个项目时,我这样配置

<VirtualHost *:80>
ServerName www.a1.com
DocumentRoot "/opt/www/a1"
<Directory "/opt/www/a1">
    Options Indexes FollowSymLinks Multiviews
    AllowOverride all 
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>


NameVirtualHost *:80
<VirtualHost *:80>
ServerName www.a2.com
DocumentRoot "/opt/www/a2"
<Directory "/opt/www/a2">
   Options Indexes FollowSymLinks Multiviews
    AllowOverride all 
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

这样访问 www.a1.com 和www.a2.com 都是一样的,都是a1 项目


怎么设置 www.a1.com  访问的是项目a1,www.a2.com  访问的是项目a2呢



大神,指点一下啊,谢谢,快崩溃了

以下是问题补充:

@玉良:Apache/2.2.24 (Unix) PHP 5.3.25 (cli) (built: May 21 2013 17:24:33) Copyright (c) 1997-2013 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies (2013/07/05 13:49)
加载中
0
南湖船老大
南湖船老大

严格按照此文配置,要是还不对你来打我

http://blog.minidx.com/2008/04/12/708.html

玉良
玉良
谢谢
南湖船老大
南湖船老大
回复 @张志祥 : 我刚忘发链接了 你再看看
玉良
玉良
(#哭) 我不想打人,只想把问题解决,新手,伤不起啊 0.0
0
OpenIoT
OpenIoT
httpd.conf中的 # Include conf/extra/httpd-vhosts.conf ,把#给去掉了吗?
OpenIoT
OpenIoT
回复 @张志祥 : 那在httpd.conf,加上这句话:NameVirtualHost 你的IP
玉良
玉良
里面,没有这句话,配置信息,写在httpd.conf里面,不就行吗?
0
OpenIoT
OpenIoT
错了,不是你的IP,是WEB服务器IP,举例: NameVirtualHost 8.8.8.8
玉良
玉良
刚才试了下,还是不行
0
玉良
玉良
原来,我写的没错,wordpress 需要后台设置,谢谢上位的两位大哥 
返回顶部
顶部