Pyqery的安装问题

RobinsonLiao 发布于 2012/12/03 22:25
阅读 611
收藏 0

@红薯 你好,想跟你请教个问题:

介绍了Pyqery,能否给个详细完整的安装过程,网上其它文章太过简略,省却关键出错的地方

并不是easy_install就可以搞定的事情

加载中
0
铂金胖子
铂金胖子
出啥错了?要装lxml
0
嘿哟传说
嘿哟传说
还是先安装lxml包,pyquery是基于lxml的,如果是在window,就搜一下两个exe的安装包吧
0
RobinsonLiao
RobinsonLiao
我是windows下,刚开始easy_install pyquery的时候,倒是可以装,然后自动搜索它的依赖包,就是lxml,它倒是能找到lxml3.0.1,但也就到此为止,网上搜搜,说装lxml又要先装2个其它的库,其它2个库怎么弄发,没具体说,这么麻烦?
0
RobinsonLiao
RobinsonLiao
还有文章,是直接easy_install --allow-hosts=lxml.de,*.python.org lxml==2.2.2 就搞定
还有文章说要先安装Cython.
0
Narky
Narky

没这么麻烦,到这里 http://pypi.python.org/pypi/lxml/2.2.8 找你python版本对应的包,装上就行了

据说推荐是用2.2.x系列的比较好

0
RobinsonLiao
RobinsonLiao

最新的3.0.1貌似么有这么分包,是属于支持Py3的版本么

Narky
Narky
3.0.1是源码版本,好像还没有egg包
0
RobinsonLiao
RobinsonLiao

看文章说,正则的速度最快,pyquery,beautifulsoap,次之,htmlpaser最慢?

返回顶部
顶部