项目部署到Cloud Foundry报错:SEVERE: Context [] startup failed due to previous errors

华兹格 发布于 2013/01/16 20:42
阅读 5K+
收藏 0

报错日志:

Jan 16, 2013 12:33:25 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-9278
Jan 16, 2013 12:33:25 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 381 ms
Jan 16, 2013 12:33:25 PM org.apache.catalina.realm.JAASRealm setContainer
INFO: Set JAAS app name Catalina
Jan 16, 2013 12:33:25 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jan 16, 2013 12:33:25 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
Jan 16, 2013 12:33:25 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
Jan 16, 2013 12:33:25 PM org.apache.catalina.core.StandardContext start
SEVERE: Error filterStart
Jan 16, 2013 12:33:25 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [] startup failed due to previous errors
Stopping Tomcat because the context stopped.
现在是:2013 1 16 20:35,但报错时间却是12:33,不知为啥。开始报错还是10:20分左右的,因为我在10:20分钟左右试过一次,但从来就没有成功过!

还请大牛给我指点下,这个问题已经折磨我好久了!多谢了!

加载中
1
缪斯的情人
缪斯的情人

问题不是很明显,目测是由于编译版本不一致导致的。看SEVERE: Error filterStart这是关键,让问题暴漏出来就把web.xml的filter先注释掉,重启服务器,这时候就会出现具体异常信息了。猜测两种原因导致:1.缺少必要的jar包 2.编译版本和部署版本的jdk不一致导致。good luck!

1
华兹格
华兹格
结贴:通过上面的错误日志是无法看出端倪的,即使能也不全面。推荐的做法是下载Eclipse的插件,可以查看详细的错误日志,一般错误会是在数据库密码上面,可以看我的另一篇博客:

使用Eclipse插件或VMC布署Cloud Foundry应用

 
0
黄平俊
黄平俊

确认JDK是否为1.6版本的?
再确认JDBC是否用传统的连接?

d
dsfsdxiao
多谢
0
zkool
zkool
同样的错误,咋整的,楼主
0
JFinal
JFinal

引用来自“zha0ku1”的答案

同样的错误,咋整的,楼主
部署环境下的 jdk 版本低于项目开发环境jdk版本造成的
uknow8692
uknow8692
回复 @zkool : 你好,我也遇到和你一样的问题了,也是找不到applicationContext.xml。请问你是怎么解决的?我也用了jfinal
zkool
zkool
费了好大劲,才发现,我的情况是用JFinal的Spring插件时,部署到linux环境下报的错误,找不到/WEB-INF/applicationContext.xml,网上查的资料,路径前“file:”或者“/”如new SpringPlugin("file:"+PathKit.getWebRootPath() + "/WEB-INF/applicationContext.xml")
JFinal
JFinal
回复 @zha0ku1 : 降低开发环境的 JDK编译级别,或者提高部署环境JDK版本都行
zkool
zkool
项目部署不上去了,肿么搞啊,用jdk1.5的也不行啊
返回顶部
顶部