CasperJS 的安装和快速入门

红薯 发布于 2012/05/30 14:13
阅读 11K+
收藏 30

CasperJS 是一个开源的导航脚本和测试工具,使用 JavaScript 基于 PhantomJS 编写,用于测试 Web 应用功能,Phantom JS是一个服务器端的 JavaScript API 的 WebKit。其支持各种Web标准: DOM 处理, CSS 选择器, JSON, Canvas, 和 SVG。

本文主要介绍如何安装和使用 CasperJS 工具。

安装

CasperJS 依赖于PhantomJS >= 1.3 ,强烈建议使用 PhantomJS 1.5 版本,PhantomJS 的安装非常简单,下载后解压就可以使用,详情请看 PhantomJS' 安装指南

安装完 PhantomJS 后你可以在命令后下检查版本信息:

$ phantomjs --version
1.5.0

接下来我们开始安装 CasperJS:

$ git clone git://github.com/n1k0/casperjs.git
$ cd casperjs
$ git checkout tags/0.6.9
$ ln -sf `pwd`/bin/casperjs /usr/local/bin/casperjs

你也可以直接下载打包好的文件(0.6.9.zip),解压后执行上述脚本的第4个命令.

然后检查安装是否成功:

$ casperjs --version
0.6.9

安装完毕, 现在可以开始写我们的脚本了.

注: casperjs 命令是用 Python 脚本编写, 也可以使用 Python 来执行:

$ python /path/to/casperjs/bin/casperjs
CasperJS version 0.6.9 at /Users/niko/casperjs
Usage: casperjs script.(js|coffee) [options...]
Read the docs http://casperjs.org/

所以要确保你机器上的 Python 环境是OK的.

接下来你可以阅读这篇文章:使用 CasperJS 对 Web 网站进行功能测试

OSCHINA原创翻译
加载中
0
bobshi
bobshi
windows 下可以安装和使用吗?
bobshi
bobshi
回复 @红薯 : 哦,在http://casperjs.org/faq.html#faq-executable这里找到答案了。不过dos打出来的中文信息乱码了,-_-|||
红薯
红薯
可以哦
0
韩师傅
韩师傅

CasperJS支持在Ruby下运行了,并且安装方式很简单,运行

gem install casperjs

未发布正式版之前可能需要运行

gem install casperjs --pre

安装完即可使用

$casperjs -v
1.0.0.RC1

对于没有Python环境的同学,这是一个不错的选择。


0
帖子列表
帖子列表
怎样把它装在树莓派上?
0
摩天轮GYH

安装了phantomjs 2.1.1版本,但是casperjs --version 提示:CasperJS needs at least PhantomJS v1.5.0。phantomjs的环境变量和casperjs的环境变量都设置了,可直接访问,这是怎么回事呢?

返回顶部
顶部