在 Linux 下安装 Ekho 中文文本转语音引擎

红薯 发布于 2012/05/06 20:30
阅读 5K+
收藏 0

如果你使用的是Ubuntu Linux 8.04,你可以通过下面的指令获取deb包并执行以下命令:

$ sudo dpkg -i ekho_x.y-zzz.i386.deb

你也可以通过下面的指令从源代码编译:

$ tar xjvf ekho-xxx.tar.bz2
$ cd ekho-xxx
$ ./configure
$ make
$ sudo make install
$ ekho "hello"

如果上面的命令安装不成功,通常是因为缺少libsndfile、libportaudio、libvorbis-dev和liblame-dev的软件包。请阅读数据包里的INSTALL说明文件。

关于余音的用法,请通过以下命令获取:

$ ekho -h

文章转自 Ekho 文档

加载中
0
l
liuchunjing

红薯, 请教个问题:

./configure,这一步我没有执行通过,

configure: error: in `/usr/local/ekho-5.0.7':

configure: error: sndfile test failed

See `config.log' for more details
最终是怎么解决?


0
n
niceman

我也遇到这个问题了

./configure

.....

configure: error: in `/root/dreamstart/ekho-5.2':

configure: error: sndfile test failed

0
n
niceman

执行下面的命令就可以了

locate sndfile

ln -s /usr/lib/libsndfile.so.1.0.20 /usr/lib/libsndfile.so

0
n
niceman

./configure 成功后执行make出现如下错误:

src/ekho.h:25:21: error: sndfile.h: No such file or directory

src/phonetic_symbol.h:76: error: ‘SF_INFO’ has not been declared

....

执行

yum install libsndfile libsndfile-devel

ok,编译成功

0
小楼一夜听春雨
请教, linux下,测试  ekho "你好"  语速太快,听不清,windows 下正常。何解?
0
jackdongy_cc
jackdongy_cc
请教,如何让ekho支持英文发音,我编译的是5.04和5.2版本,只要加上./configure   --enable-festival 这个参数,编译就出错,不加上这个参数,编译后不能读英文,只能读中文和数字。
0
罗培

请教下:

我这边装了依赖的包 为什么还是不行。现在装的Ekho5.7,依赖包如图所示

./config的时候报错:

configure: error: in `/usr/ekho-5.7':

configure: error: sndfile test failed 

0
罗培
图片发错了...
返回顶部
顶部