64 位的 Linux 下难道真的就无法安装 QQ 客户端了吗?

红薯 发布于 2009/11/05 13:15
阅读 4K+
收藏 1

装了个 Ubuntu 9.10 x64 位版本,可到QQ网站上看,所有的版本都是32位的。

有什么解决办法捏?? 难道只能用 webqq ?

腾讯不至于连 64 位的QQ都做不出来把??

加载中
0
h
huruxing159

可以   下载一个for linux版本的 不是for ubuntu 的  然后解压到桌面 。有两个文件。其中一个是可执行的文件,双击运行就ok

还有一种办法就是使用 for ubuntu i386的强制安装就可以了。。不过在9.10下可能存在自动关闭的问题

0
红薯
红薯

引用来自“huruxing159”的帖子

可以   下载一个for linux版本的 不是for ubuntu 的  然后解压到桌面 。有两个文件。其中一个是可执行的文件,双击运行就ok

还有一种办法就是使用 for ubuntu i386的强制安装就可以了。。不过在9.10下可能存在自动关闭的问题

都跟你说是 64位 Linux 的了。

0
林刚

完全可以,我用的是fedora 12 X64版本,直接可以用RPM安装或者直接将那个源码下载解压开了就可以用,64位版本和ibus有些冲突,yum -y install ibus-gtk.i686 即可解决,linux下的qq没有聊天记录保存,每个人只保存20条记录,非常垃圾!

0
l
lcsky

最郁闷的是没有提示音,个人觉得还是Chrome+WebQQ好啊~~~

0
h
huruxing159

引用来自“红薯”的帖子

引用来自“huruxing159”的帖子

可以   下载一个for linux版本的 不是for ubuntu 的  然后解压到桌面 。有两个文件。其中一个是可执行的文件,双击运行就ok

还有一种办法就是使用 for ubuntu i386的强制安装就可以了。。不过在9.10下可能存在自动关闭的问题

都跟你说是 64位 Linux 的了。

可以强制安装的  貌似加个  - - force- 具体什么参数忘记了。

可以强制安装上

我的也是64位的。

0
曾赛
曾赛

WEB QQ,呵呵,挺漂亮的!

0
s
six6jf

sudo dpkg -i --force-all filename

执行上述代码可以强行安装。但使用时稳定性怎样就不知道了。

0
红薯
红薯

引用来自“six6jf”的帖子

sudo dpkg -i --force-all filename

执行上述代码可以强行安装。但使用时稳定性怎样就不知道了。

的确可以,非常感谢 :)

0
b
boubalos
可以强制安装deb包:
> sudo dpkg -i --force-all linuxqq_v1.0.2-beta1_i386.deb

推荐直接官方下载普通的32位2进制版:linuxqq_v1.0.2_i386.tar.gz

 



64位系统运行32位的qq程序需要预先安装:
> sudo apt-get install ia32-libs ia32-libs-gtk


安装完后,运行QQ,可能图形界面有点小问题,终端中报错:
Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

解决办法:
从http://packages.debian.org/wheezy/i386/gtk2-engines-murrine/download下载gtk2-engines-murrine_0.98.1.1-5_i386.deb,把libmurrine.so提取出来,并放到/usr/lib32/gtk-2.0/2.10.0/engines/libmurrine.so

运行QQ前,设置环境变量:

export GTK_PATH=/usr/lib32/gtk-2.0

如果是从linuxqq_v1.0.2_i386.tar.gz解压来的,需要确保运行时目录下(pwd),同时有qq和res.db这两个文件
0
h
hhcczz
你是这样安装的吗,参考一下: QQ for linux解决方案!(分享经验)
返回顶部
顶部