J2Cache 项目结构的重整以及升级依赖包到最新版本

红薯 发布于 2015/09/15 19:01
阅读 90
收藏 0

#J2Cache# http://git.oschina.net/ld/J2Cache 项目是开源中国开发的一个两级缓存框架。目前该项目还在使用老版本的 #jedis# 和 #jgroups# jar 包。由于最新的 jedis 和 jgroups 在 API 上有一些变化,先需要对这两个依赖包进行升级。

此悬赏包含两项任务:

1. 升级 jedis 和 jgroups 到最新版本

2. 对 Hibernate 的支持进行结构调整,j2cache 支持 hibernate3 和 hibernate4,但因为对 jar 包依赖的冲突,目前两个版本是在不同的分支下进行的。这次调整首先要删除分支,同一个分支实现对不同 hibernate 版本的支持。请通过私信沟通具体的解决方案。

参与悬赏方法:

1. 点击本页面的报名
2. 通过审核后 Fork 项目 http://git.oschina.net/ld/J2Cache
3. 在 fork 的项目中进行上述调整后提交 pull requests
4. 我们会有专人根据提交 PR 的顺序进行测试,测试通过后付款

由于这是一个开源项目,预算有限,为开源贡献,欢迎大家踊跃参加。

加载中
0
如比如比
如比如比
我是来围观的
0
Codeyn
Codeyn
不错,不错
0
bluesky4485
bluesky4485
这个升级我早做了,不过我去掉了对Hibernate的支持。
0
红薯
红薯

引用来自“bluesky4485”的评论

这个升级我早做了,不过我去掉了对Hibernate的支持。
那报名参与一下悬赏吧:)
0
bluesky4485
bluesky4485

引用来自“bluesky4485”的评论

这个升级我早做了,不过我去掉了对Hibernate的支持。

引用来自“红薯”的评论

那报名参与一下悬赏吧:)
好吧,我对Hibernate不熟啊,抽空研究下看看吧
0
DuLerWeil
DuLerWeil
jedis倒折腾过,jgroups得先研究下
0
pank
pank
@红薯 悬赏为啥不能关注啊,建议加个关注么
0
红薯
红薯

引用来自“pank”的评论

@红薯 悬赏为啥不能关注啊,建议加个关注么
没什么好关注的,做完就完啦 :) 不过回头可以考虑 @成熟的毛毛虫
0
沃德天拉莫帅
沃德天拉莫帅

引用来自“pank”的评论

@红薯 悬赏为啥不能关注啊,建议加个关注么

引用来自“红薯”的评论

没什么好关注的,做完就完啦 :) 不过回头可以考虑 @成熟的毛毛虫
ok
返回顶部
顶部