jQuery 1.5 + FancyBox 在 IE9 下的问题

红薯 发布于 2011/02/14 13:48
阅读 1K+
收藏 1

今天在做个人空间改版的时候发现了这样一个问题:

软件:

jQuery 1.5 正式版
FancyBox 1.3.4

使用的是最新的 IE9 RC 版本,无法打开 FancyBox 弹出窗口

而换成 jQuery 1.4.x 版本后,就可以正常显示。

但其他一些跟 FancyBox 无关的 jQuery 的方法可以正常执行。

估计是 FancyBox 跟 jQuery 1.5 的兼容问题。

另外在其他浏览器下无此问题,IE的其他版本也无此问题。

加载中
0
红薯
红薯

看来要等 FancyBox 发布补丁版本,才敢上 jQuery 1.5 了。

0
Jiang Hongfei
Jiang Hongfei

貌似是getElementsByTag的错误,可以看看这个:http://bugs.jquery.com/ticket/8052。不过看样子这个问题不会在1.5里面解决,除非自己改代码:

Please do not use the code prescribed by Soul_Master. It is quite wrong. If you want to work around this problem, use jQuery.support.noCloneEvent = !!window.addEventListener instead. It will be resolved in 1.5.1.

0
星星王
星星王

改他源码

返回顶部
顶部