Eclipse 安装对 Java 8 的支持

红薯 发布于 2014/03/19 10:06
阅读 13K+
收藏 17

Java 8 正式版今天已经发布了(详情),但最常用的 Java 开发工具 Eclipse 还没有正式发布对 Java 8 的支持。不过目前可以通过更新 JDT 来支持 Java 8。步骤如下:

  1. 菜单:Help > Install New Software...
  2. 输入如下 URL 地址:
    http://build.eclipse.org/eclipse/builds/4P/siteDir/updates/4.3-P-builds
  3. 按回车键
  4. 选择分类 'Eclipse Java 8 Support (BETA)'
  5. 为了更快速的安装,请不要选择 'Contact all updates sites during install to find required software'
  6. 点击 'Next'
  7. 点击 'Next'
  8. 接受协议
  9. 点击 'Finish'
  10. 重启 Eclipse

加载中
1
ptrr
ptrr
我的安装不成功!呵呵
ptrr
ptrr
回复 @红薯 : 我再试试,
红薯
红薯
我已经搞定了,安装完在编译器选项里有个 Java 8 (Beta)
0
随影求是
随影求是
估计正式版要4.4才支持
0
黄道坤
黄道坤

Version 1.8 of project facet java does not exist
有人遇到了么?

何解?

0
karamay00
karamay00

"Eclipse Java Development Tools Patch for Java 8 Support (BETA)" is not applicable to the current configuration and will not be installed.

"Eclipse Plug-in Development Environment Patch for Java 8 Support (BETA)" is not applicable to the current configuration and will not be installed.

我用的ADT,没有安装成功……


0
绝望生鱼片
绝望生鱼片
4.2能装吗?4.3不支持反编译的插件。。。
绝望生鱼片
绝望生鱼片
@阿信sxq 我试试~谢谢哈
阿信sxq
阿信sxq
http://jd.benow.ca/jd-eclipse/update,这个反编译插件,我在4.3.2上都可以成功运行
0
不是小白
不是小白
我表示现在还是不习惯OSC的新版,还改成以前的吧
0
千金之躯
千金之躯
java8终于姗姗来迟了
0
劲风
劲风

4.3版的,安装成功。没有安装成功的,注意第5条。

0
tianyun
tianyun

安装成功。junit还不支持。呵呵

OSCHINA
登录后可查看更多优质内容
返回顶部
顶部