Ubuntu 的服务器只能本机登录SSH,其他机器连接过来报连接拒绝

红薯 发布于 2013/12/23 14:08
阅读 4K+
收藏 0

公司内部的开发服务器,装的是 Ubuntu 服务器版本。

这两天突然就无法使用 ssh 连接服务器,但是直接在控制台上可以 ssh xxx@localhost 连接。

这是为何啊? 用 iptables -F 禁用防火墙也一样无法连接

加载中
0
MrZQ
MrZQ
SecureCRT也不可以吗?
MrZQ
MrZQ
回复 @红薯 : 那就是RP问题了~
红薯
红薯
回复 @MyKings : 老兄啊,你这是把我当初学者来对待啊,呵呵
MrZQ
MrZQ
回复 @红薯 : 是否在同一个网段?
红薯
红薯
回复 @MyKings : 网络正常的
MrZQ
MrZQ
回复 @红薯 : ping丢包不
下一页
0
Foou
Foou

我的步骤:

先远程 telnet 服务器ip 22 看端口是否开放。

如果端口开,可能是ssh的问题,重启下 sshd试试,在看监听的端口绑定的ip是否正确

如果端口不开那就检查 itpables 或 sshd。


0
ththththht
ththththht

关闭SELINUX试试
vi /etc/selinux/config
#SELINUX=enforcing #注释掉
#SELINUXTYPE=targeted #注释掉
SELINUX=disabled #增加

shutdown -r now

0
szf
szf

ssh -v xxxx@hhhhh

看看debug信息

0
Cycle_C
Cycle_C
/etc/hosts.deny修改过?
0
蟋蟀哥哥
蟋蟀哥哥
长相问题
主编
主编
+1
0
eechen
eechen
使用ufw开放22端口(ufw仍是调用iptables):
sudo ufw enable

sudo ufw default deny
sudo ufw allow 22/tcp

/etc/ssh/sshd_config 注意这个项:

PermitRootLogin yes #允许root用户登录
PasswordAuthentication yes # 允许密码认证
PubkeyAuthentication yes # 允许密钥认证
sudo service ssh restart

假设Ubuntu的IP为192.168.0.10
用netcat看能否连上22端口:
nc -v 192.168.0.10 22

使用root用户重新登录试试看:
ssh root@192.168.0.10

0
雷毅
雷毅

好了没?我见的这些处理步骤:

telnet 服务器,如果看不到 Escape character is '^]'. 提示,则通常有两个原因,一是防火墙阻挡,二是错误地配置成了 bind listen 到 127.0.0.1 地址上了。你这看起来不是防火墙原因,就看看bind情况吧。默认bind到 0.0.0.0:22 上的

如果telnet看到了Escape character is '^]'. 提示,则通常有两个原因,一是 sshd 的安全配置策略,通常对root进行的多;二是激活了DNS反向解析导致半分钟甚至5分钟才出系统欢迎信息

0
妈她亲我
妈她亲我
ubuntu表示从没遇到过这种问题
返回顶部
顶部