4
回答
Ubuntu-14.04.1安装问题
百度AI开发者大赛带你边学边开发,赢100万奖金,加群:418589053   
安装MySQL Workbench
sudo dpkg -i mysql-workbench-community-6.2.3-1ubu1404-amd64.deb
(正在读取数据库 ... 系统当前共安装有 156278 个文件和目录。)
Preparing to unpack mysql-workbench-community-6.2.3-1ubu1404-amd64.deb ...
Unpacking mysql-workbench-community (6.2.3-1ubu1404) over (6.2.3-1ubu1404) ...
dpkg: dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community 依赖于 libctemplate2;然而:
  未安装软件包 libctemplate2。
 mysql-workbench-community 依赖于 libgtkmm-2.4-1c2a (>= 1:2.24.0);然而:
  未安装软件包 libgtkmm-2.4-1c2a。
 mysql-workbench-community 依赖于 libtinyxml2.6.2;然而:
  未安装软件包 libtinyxml2.6.2。
 mysql-workbench-community 依赖于 libzip2 (>= 0.10);然而:
  未安装软件包 libzip2。
 mysql-workbench-community 依赖于 python-paramiko;然而:
  未安装软件包 python-paramiko。
 mysql-workbench-community 依赖于 libproj0;然而:

  未安装软件包 libproj0。

dpkg: error processing package mysql-workbench-community (--install):
依赖关系问题 - 仍未被配置
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
在处理时有错误发生:
 mysql-workbench-community

----------------------------------------------------------------------------------------------------------------

安装 nodejs
 sudo apt-get install nodejs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
 libmysqlclient16:i386 : 依赖: libc6:i386 (>= 2.4) 但是它将不会被安装
                         依赖: zlib1g:i386 (>= 1:1.1.4) 但是它将不会被安装
 libzip1:i386 : 依赖: libc6:i386 (>= 2.7) 但是它将不会被安装
                依赖: zlib1g:i386 (>= 1:1.1.4) 但是它将不会被安装
 mysql-workbench-community : 依赖: libctemplate2 但是它将不会被安装
                             依赖: libgtkmm-2.4-1c2a (>= 1:2.24.0) 但是它将不会被安装
                             依赖: libtinyxml2.6.2 但是它将不会被安装
                             依赖: libzip2 (>= 0.10) 但是它将不会被安装
                             依赖: python-paramiko 但是它将不会被安装
                             依赖: libproj0 但是它将不会被安装
 nodejs : 依赖: libc-ares2 (>= 1.8.0) 但是它将不会被安装
          依赖: libv8-3.14.5 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
 

----------------------------------------------------------------------------------------------------------------

安装libjs-extjs
 sudo apt-get install libjs-extjs 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
 libjs-extjs : 依赖: javascript-common 但是它将不会被安装
 libmysqlclient16:i386 : 依赖: libc6:i386 (>= 2.4) 但是它将不会被安装
                         依赖: zlib1g:i386 (>= 1:1.1.4) 但是它将不会被安装
 libzip1:i386 : 依赖: libc6:i386 (>= 2.7) 但是它将不会被安装
                依赖: zlib1g:i386 (>= 1:1.1.4) 但是它将不会被安装
 mysql-workbench-community : 依赖: libctemplate2 但是它将不会被安装
                             依赖: libgtkmm-2.4-1c2a (>= 1:2.24.0) 但是它将不会被安装
                             依赖: libtinyxml2.6.2 但是它将不会被安装
                             依赖: libzip2 (>= 0.10) 但是它将不会被安装
                             依赖: python-paramiko 但是它将不会被安装
                             依赖: libproj0 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


-----------------------------------------------------------------------------------------------------------------
↑以上是在ubuntu下啊安装是出现的问题,怎么解决或者是在哪里下载这些依赖包
举报
顶部