jqueryEasyUI在IE9和火狐上面的兼容问题

qjf_Troy 发布于 2013/11/20 11:27
阅读 5K+
收藏 0

 

这个是我的代码的截图,刚开始接触easyUI想自学呢,结果发现就这么一个简单的功能在IE9上面无法显示,我查了半天代买也不知道是怎么回事,结果在火狐上面一看我的代码运行正常没有问题,然后在网上找了下为什么在IE9和火狐上面的兼容不同,结果没有找到实质性的结果,哪位大侠要是知道可否告知一二,在此先谢过了!

加载中
0
xiaohe24
xiaohe24

引用来自“刘子玄”的答案

对了,很重要的一点,用最新的2.x版的jquery,不要用旧版的
错了,IE9用不了是因为easyui1.3.3里的jquery是2.0版本的,换个1.*版本的jquery就ok
0
吐槽的达达仔
吐槽的达达仔
引入jquery的顺序错了。。先jquery,再有easyUI
0
qjf_Troy
qjf_Troy

引用来自“吐槽的达达仔”的答案

引入jquery的顺序错了。。先jquery,再有easyUI

啊,还有这一说么,我试试先

0
qjf_Troy
qjf_Troy

引用来自“吐槽的达达仔”的答案

引入jquery的顺序错了。。先jquery,再有easyUI
还是不行我把顺序改过来了,还是一样的在IE9中还是只弹出第一个alert,后面的就没走,并且IE9的状态栏也不提示什么错误
0
qjf_Troy
qjf_Troy

有没有人越到过呀,给一个解释呀

0
Jackitshot
Jackitshot

http://blog.csdn.net/xpsharp/article/details/8898681

能否解决你的问题?

0
Polle
Polle
IE9没大问题,我开发主要用Chrome,完全根据标准来,JS也完全不考虑兼容IE。但在IE9下也能正常运行。IE9应该是没问题的。
0
qjf_Troy
qjf_Troy

引用来自“Jackitshot”的答案

http://blog.csdn.net/xpsharp/article/details/8898681

能否解决你的问题?

这个还是不行,怪了在chrome和火狐上面都好着呢,结果在ie9中就是不行

0
qjf_Troy
qjf_Troy

引用来自“刘子玄”的答案

IE9没大问题,我开发主要用Chrome,完全根据标准来,JS也完全不考虑兼容IE。但在IE9下也能正常运行。IE9应该是没问题的。

我得很奇怪对chrome和火狐都好着呢,结果在ie9上面无法显示,但是也不报错

Polle
Polle
估计是你用了非标准的东西,IE9支持大部分标准和目前主流的js用法。
0
Polle
Polle
对了,很重要的一点,用最新的2.x版的jquery,不要用旧版的
返回顶部
顶部