一个系统可以两个版本的php并存吗?

regalechinajava 发布于 2016/02/25 10:45
阅读 1K+
收藏 0

原系统win2003 iis php5.2

现在有系统要用php5.4.

能再原来的系统上再装5.4,5.2和5.4共用吗?

加载中
1
r
regalechinajava
自己搞定了,利用IIS标识符
0
两只小蜜蜂啊
两只小蜜蜂啊
见过有的高手实现过,我也准备学这个。。。
0
SaltyEgg
SaltyEgg

可以,但是一个apache(如果你用的是apache的话)同一时刻应该只能运行一个php版本,你需要自己手动切换。

http://www.phpstudy.net/a.php/208.html 就支持多个,你可以参考一下

0
卖爷爷的老红薯
卖爷爷的老红薯
一万个也可以!
0
碳素云信息技术
碳素云信息技术
可以。不管是apache方案还是nginx+php-fpm方案都可以多个并存的。
0
eechen
eechen
IIS不清楚.但Nginx跟PHP-FPM的组合就太简单了,不同版本的PHP-FPM监听不同端口或者Unix Domain Socket就行.至于Apache+libphp.so的模式,要跑多个PHP版本,则需要跑多个Apache,也就是不同Apache监听不同端口载入不同版本的libphp.so模块.
返回顶部
顶部