1
回答
jboot升级到1.6.4之后启动provider服务 找不到motan包的相关类文件
开发十年,就只剩下这套Java开发体系了   

之前是用的1.4.3的jboot版本,最近想升级到1.6.4. 之后发现shiro和com.weibo相关依赖找不到,然后手动解决了依赖. 后面在启动provider服务器的时候出现以下报错:

java.lang.NoClassDefFoundError: com/weibo/api/motan/config/AbstractInterfaceConfig
	at io.jboot.core.rpc.JbootrpcManager.createJbootrpc(JbootrpcManager.java:106)
	at io.jboot.core.rpc.JbootrpcManager.getJbootrpc(JbootrpcManager.java:53)
	at io.jboot.core.rpc.JbootrpcManager.init(JbootrpcManager.java:63)
	at io.jboot.web.JbootAppConfig.afterJFinalStart(JbootAppConfig.java:223)
	at com.jfinal.core.JFinalFilter.init(JFinalFilter.java:56)
	at io.undertow.servlet.core.LifecyleInterceptorInvocation.proceed(LifecyleInterceptorInvocation.java:111)
	at io.undertow.servlet.core.ManagedFilter.createFilter(ManagedFilter.java:80)
	at io.undertow.servlet.core.DeploymentManagerImpl$2.call(DeploymentManagerImpl.java:589)
	at io.undertow.servlet.core.DeploymentManagerImpl$2.call(DeploymentManagerImpl.java:554)
	at io.undertow.servlet.core.ServletRequestContextThreadSetupAction$1.call(ServletRequestContextThreadSetupAction.java:42)
	at io.undertow.servlet.core.ContextClassLoaderSetupAction$1.call(ContextClassLoaderSetupAction.java:43)
	at io.undertow.servlet.core.DeploymentManagerImpl.start(DeploymentManagerImpl.java:596)
	at io.jboot.server.undertow.UnderTowServer.initUndertowServer(UnderTowServer.java:104)
	at io.jboot.server.undertow.UnderTowServer.start(UnderTowServer.java:192)
	at io.jboot.Jboot.startServer(Jboot.java:168)
	at io.jboot.Jboot.start(Jboot.java:149)
	at io.jboot.Jboot.run(Jboot.java:92)
	at com.mi.hx.finance.core.service.provider.app.ProviderCoreApplication.main(ProviderCoreApplication.java:12)
Caused by: java.lang.ClassNotFoundException: com.weibo.api.motan.config.AbstractInterfaceConfig
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 18 more

确定consul服务器已启动。依赖xml也已经添加了。麻烦海哥帮我看下@海哥

 

 

举报
枫亭子
发帖于1个月前 1回/113阅
顶部