Elastic-job 不支持zookeeper-3.5.1-alpha版本吗

lmiky 发布于 2017/06/13 15:17
阅读 914
收藏 0

Serverless 架构就不要服务器了?>>>

项目中原先已经引入了zookeeper-3.5.1-alpha和curator-2.11.0,一直在运行没有问题。

今天引入Elastic-job-2.1.3之后,tomcat启动报“KeeperErrorCode = ConnectionLoss for”异常,把zookeeper改为3.4.6就正常启动,但是如果改动版本,可能会影响到其他线上的业务,所以想问下是Elastic-job不支持zookeeper-3.5.1-alpha。

加载中
0
k
kawencs

是不是Curator版本和支持的zookeeper版本不一致导致的,坐等亮哥确认一下。

0
l
lmiky

引用来自“kawencs”的评论

是不是Curator版本和支持的zookeeper版本不一致导致的,坐等亮哥确认一下。

应该不是,线上已有的业务一直在运行,没有错误

0
张亮_Apache
张亮_Apache

我没试过其他的zk版本,不过我感觉可能就是curator版本导致的,curator版本和zk的版本应该是对应的。

返回顶部
顶部