Permission denied: user=***, access=WRITE, inode="staging":root:supergroup:rwxr-xr-x

jack_peng 发布于 2013/09/06 01:36
阅读 10K+
收藏 0

今天在eclipse中运行hadoo的代码例子 ,发现了这个权限的问题 ,好像不网上说的办法都解决不到,说要把当前用户改为hadoop才可以解决?

hadoop 下/user/hadoop 权限只有root 才能进去 ,但在代码中我又不知道怎么用root用户去登陆,哎纠结呢,一想能不能/user 这个文件的权限改为 777 呢 ,我索性把 hadoo dfsadmin safemode leave 关了,把/user 这个权限改了,结果一启动程序,又报safemode问题的错误, 弄的连eclipse的hadoop hdfs 功能都不能用鸟,郁闷了。求高手指点下方向呢

加载中
0
孤单时会想你
孤单时会想你
试试chmod +x /user/hadoop chmod -R 777 /user/hadoop
jack_peng
jack_peng
明显不行三,在eclipse代码中跑不行,但运行官方的examples。jar就可以。why
0
道友慢走
道友慢走
让eclipse以root权限启动试试。
0
阑珊涙
兄弟,你的问题解决了吗,我刚在eclipse下配完hadoop插件,但是hadoop安装在另一个用户下,这样的话,在DFS Location下,无法对那些文件进行删除,新建等操作,提示的最后一行和你说的和你说的一样
yosef
yosef
回复 @jack_peng : 必须要用root吗? 如果换成其它帐号应该怎么处理?
jack_peng
jack_peng
问题解决了 ,你用root 用户进去 就解决这个问题了
0
追着太阳晒
追着太阳晒
我也出现这个问题,求解啊~~
0
LindaYack
LindaYack

http://www.cnblogs.com/acmy/archive/2011/10/28/2227901.html

解决方法:

  到服务器上修改hadoop的配置文件:conf/hdfs-core.xml, 找到 dfs.permissions 的配置项 , 将value值改为 false

<property>
<name>dfs.permissions</name>
<value>false</value>
<description>
If "true", enable permission checking in HDFS.
If "false", permission checking is turned off,
but all other behavior is unchanged.
Switching from one parameter value to the other does not change the mode,
owner or group of files or directories.
</description>
</property>

修改完貌似要重启下hadoop的进程才能生效

BluesMao
BluesMao
谢谢!按照修改就可以了
返回顶部
顶部