ntop 安装错误??

y88182472 发布于 2009/06/11 15:31
阅读 1K+
收藏 0

[root@centos ntop-3.3.9]# yum install ntop
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package ntop.i386 0:3.3.8-1.el5.rf set to be updated
--> Processing Dependency: librrd_th.so.2 for package: ntop
--> Finished Dependency Resolution
Error: Missing Dependency: librrd_th.so.2 is needed by package ntop


搞这个NTOP 搞的很郁闷,,,搞了几天,还是配置不成功..

谁能帮我解决这个问题??

加载中
0
范堡
范堡

缺少了rrdtool-devel    这个按软件的安装,详细看以下安装教程

http://www.diybl.com/course/6_system/linux/Linuxjs/20090311/160625.html

0
y
y88182472

不差啊..

之前就用,  yum install  rrdtool 装过了.

0
红薯
红薯

rrdtool 跟 rrdtool-devel 是不同的

0
y
y88182472

[root@www yum.repos.d]# rpm -aq |grep rrdtool
rrdtool-devel-1.3.7-1.el5.rf
rrdtool-1.3.7-1.el5.rf
perl-rrdtool-1.3.7-1.el5.rf

0
范堡
范堡

引用来自“y88182472”的帖子

 

[root@www yum.repos.d]# rpm -aq |grep rrdtool
rrdtool-devel-1.3.7-1.el5.rf
rrdtool-1.3.7-1.el5.rf
perl-rrdtool-1.3.7-1.el5.rf

一,安装RRDtool
[root@adsl ~]# rpm -ivh perl-rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-devel-1.2
警告:perl-rrdtool-1.2.23-1.el4.rf.i386.rpm: V3 DSA 簽章:NOKEY, key ID 6b8d79e6
準備中...                   ########################################### [100%]
   1:rrdtool                ########################################### [ 33%]
   2:perl-rrdtool           ########################################### [ 67%]
   3:rrdtool-devel          ########################################### [100%]
这三个包一定要在一起安装,分开安装就不行,报如下错误(这个害的我停下一段时间):
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
[root@adsl ~]# rpm -ivh rrdtool*
警告:rrdtool-1.2.23-1.el4.rf.i386.rpm: V3 DSA 簽章:NOKEY, key ID 6b8d79e6
錯誤:相依性失敗:
        perl(RRDp) 是 rrdtool-1.2.23-1.el4.rf.i386 所需要的
        perl(RRDs) 是 rrdtool-1.2.23-1.el4.rf.i386 所需要的
[root@adsl ~]# rpm -ivh ntop*
警告:ntop-3.3-1.el4.rf.i386.rpm: V3 DSA 簽章:NOKEY, key ID 6b8d79e6
錯誤:相依性失敗:
        librrd_th.so.2 是 ntop-3.3-1.el4.rf.i386 所需要的
[root@adsl ~]#

0
y
y88182472

我直接用yum install   不能这样安装吗?

非要下载下来,,,rpm -ivh perl-rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-devel-1.2

同时装吗??

0
范堡
范堡

引用来自“y88182472”的帖子

我直接用yum install   不能这样安装吗?

非要下载下来,,,rpm -ivh perl-rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-1.2.23-1.el4.rf.i386.rpm rrdtool-devel-1.2

同时装吗??

 你就试试吧, 反正弄了这么久都还没行。

又或者你试试 yum install rrdtool*

0
y
y88182472

[root@www packages]# rpm -aq |grep rrdtool
[root@www packages]# rpm -ivh perl-rrdtool-1.3.7-1.el5.rf.i386.rpm  rrdtool-devel-1.3.7-1.el                                                                 5.rf.i386.rpm rrdtool-1.3.7-1.el5.rf.i386.rpm
Preparing...                ########################################### [100%]
   1:rrdtool                ########################################### [ 33%]
   2:perl-rrdtool           ########################################### [ 67%]
   3:rrdtool-devel          ########################################### [100%]
[root@www packages]# yum install ntop
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ntop.i386 0:3.3.8-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: librrd_th.so.2 for package: ntop
--> Finished Dependency Resolution
Error: Missing Dependency: librrd_th.so.2 is needed by package ntop

0
y
y88182472

php-rrdtool 需要装吗?装这个也是装不上.

[root@www packages]#  yum install php-rrdtool
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package php-rrdtool.i386 0:1.0.50-3.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rrdtool = 1.0.50 for package: php-rrdtool
--> Processing Dependency: librrd.so.0 for package: php-rrdtool
--> Finished Dependency Resolution
Error: Missing Dependency: rrdtool = 1.0.50 is needed by package php-rrdtool
Error: Missing Dependency: librrd.so.0 is needed by package

0
y
y88182472

楼上的,,再帮看看...

返回顶部
顶部