装个ruby也出这样的错误,请问怎么解决?

天南海北 发布于 2013/06/27 10:31
阅读 648
收藏 0

centos6下:uname -a
Linux slave01 2.6.32-358.el6.i686 #1 SMP Thu Feb 21 21:50:49 UTC 2013 i686 i686 i386 GNU/Linux

我装个ruby
yum -y install ruby ruby-lib ruby-rdoc 
出现了这样的错误,怎么解决?

Error: Package: ruby-libs-1.8.7.370-1.el5.i386 (puppetlabs-deps)
           Requires: libtk8.4.so
Error: Package: ruby-libs-1.8.7.370-1.el5.i386 (puppetlabs-deps)
           Requires: libtcl8.4.so
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
加载中
0
姜鹏飞
姜鹏飞
先装上 tcl库
0
天南海北
天南海北

引用来自“姜鹏飞”的答案

先装上 tcl库

没用

我按照官网http://www.linuxfromscratch.org/blfs/view/cvs/general/tcl.html 上的安装这里做了

yum install tcl 
yum install tcl-devel
yum install tk
yum install tk-devel
过了,照样报错。奇怪,但别的虚拟机却照常安装ruby

 一样的流程哎!

0
天南海北
天南海北

引用来自“姜鹏飞”的答案

先装上 tcl库

没用

我按照官网http://www.linuxfromscratch.org/blfs/view/cvs/general/tcl.html 上的安装这里做了

yum install tcl 
yum install tcl-devel
yum install tk
yum install tk-devel
过了,照样报错。奇怪,但别的虚拟机却照常安装ruby

 一样的流程哎!

姜鹏飞
姜鹏飞
或者装一下指定版本的!
0
kiwivip
kiwivip
残疾系统啊~
0
sevk
sevk
安装 rvm 吧, http://rvm.io
返回顶部
顶部