ubuntu安装keepalived依赖的libssl包时报错,请路过大神来瞅瞅,不胜感激

狄大人 发布于 2014/01/16 16:35
阅读 3K+
收藏 0

Linux基金会开源软件大学开源技术公开课即将上线,Kubernetes1.19实战讲解!>>>

安装keepalived的时候,./configure报错:configure: error: OpenSSL libraries are required

也就是要在ubuntu上安装libssl-dev,下载了libssl-dev_1.0.1-4ubuntu5.11_amd64.deb后,安装时:

libssl-dev 依赖于 libssl1.0.0 (= 1.0.1-4ubuntu5.11);然而:
  未安装软件包 libssl1.0.0。



因此又安装:libssl1.0.0_1.0.1-4ubuntu5.11_amd64.deb

然后就报:

root@nginx:/data/keepalived# dpkg -i libssl1.0.0_1.0.1-4ubuntu5.11_amd64.deb

dpkg:关于含有 libssl1.0.0 的 libssl1.0.0_1.0.1-4ubuntu5.11_amd64.deb:
 libssl1.0.0 破坏 openssh-client (<< 1:5.9p1-4)
  openssh-client (版本为 1:5.8p1-1ubuntu3)已存在并且 已安装。
dpkg:处理 libssl1.0.0_1.0.1-4ubuntu5.11_amd64.deb (--install)时出错:
 安装 libssl1.0.0 将破坏 openssh-client,并且
不允许反配置(--auto-deconfigure 也许会有帮助)
在处理时有错误发生:
 libssl1.0.0_1.0.1-4ubuntu5.11_amd64.deb



请问各位大神这是怎么回事儿,该如何安装?
加载中
1
月影又无痕
月影又无痕

OpenSSL libraries are required

yum install *openssl*

狄大人
狄大人
不能联网。
狄大人
狄大人
是ubuntu
0
tzliqi
tzliqi

楼主  这个问题怎么解决的,我也遇到一个类似的问题

返回顶部
顶部