php.ini无法修改date.timezone

大黄 发布于 2014/01/04 23:57
阅读 2K+
收藏 1
PHP
/php -i | grep ini
Configuration File (php.ini) Path => /usr/local/php/lib
Loaded Configuration File => /usr/local/php/lib/php.ini

修改/usr/local/php/lib/php.ini里的date.timezone

date.timezone = "Asia/Shanghai"

重启nginx php-fpm后phpinfo()里还是显示

Warning: phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set

加载中
0
狂飙的小蜗牛
大黄
大黄
这个试过了
0
qycms_cn
qycms_cn
没有办法先修改系统的时区吗?先修改系统时区吧。这个一般都比较关键。
0
leo108
leo108

php -i|grep zone  这个的输出结果是什么

0
南湖船老大
南湖船老大
英文警告已经说的很清楚了
0
xtrace
xtrace
"Asia/Chongqing" 多看文档
0
大黄
大黄
好吧,是因为我的/etc/init.d/php-fpm中php-fpm的pid路径没有设置对service php-fpm时php-fpm没有重启
返回顶部
顶部