sencha touch 用phonegap打包在安卓2.3下不能运行

luchg 发布于 2013/07/01 15:25
阅读 1K+
收藏 2
打包之后在安卓2.3系统下能打开软件 ,但是一只停留在首页,点击什么都没反应,用2.2的系统还有4.0的系统测试没问题,不知道2.3系统怎么回事,用了两个2.3系统测试过都不行,应该不是机型问题,哪位能指条明路。。。
加载中
0
魔力猫
魔力猫
我觉得是否是你用的phonegap版本和2.3不兼容呢?模拟器也有问题?
0
魔力猫
魔力猫
模拟系统如何?logCat日志有错误吗?
0
l
luchg

引用来自“魔力猫”的答案

模拟系统如何?logCat日志有错误吗?
以前报错报错找不到这个类WebResourceResponse,添加这个类之后不报错了,但是还是不能运行只显示首页 ,点击页面上的按钮都不管用,你觉得可能是什么原因呢?2.2的系统还有4.0的系统测试都可以运行,只有2.3系统不能运行
0
l
luchg

引用来自“魔力猫”的答案

我觉得是否是你用的phonegap版本和2.3不兼容呢?模拟器也有问题?

嗯,我换了个phonegap版本,点击有反映了,但是sencha touch的某些页面点击之后恢复不出来是怎么回事?

我用的tab,点击其他tab之后,再点击tab内容就是空白的了,这个是因为这个是phonegap问题,还是sencha touch问题呢

0
魔力猫
魔力猫

引用来自“luchg”的答案

引用来自“魔力猫”的答案

我觉得是否是你用的phonegap版本和2.3不兼容呢?模拟器也有问题?

嗯,我换了个phonegap版本,点击有反映了,但是sencha touch的某些页面点击之后恢复不出来是怎么回事?

我用的tab,点击其他tab之后,再点击tab内容就是空白的了,这个是因为这个是phonegap问题,还是sencha touch问题呢

又涉及到HTML5兼容性的问题了,在这点上我帮不了你。
0
l
luchg

引用来自“魔力猫”的答案

引用来自“luchg”的答案

引用来自“魔力猫”的答案

我觉得是否是你用的phonegap版本和2.3不兼容呢?模拟器也有问题?

嗯,我换了个phonegap版本,点击有反映了,但是sencha touch的某些页面点击之后恢复不出来是怎么回事?

我用的tab,点击其他tab之后,再点击tab内容就是空白的了,这个是因为这个是phonegap问题,还是sencha touch问题呢

又涉及到HTML5兼容性的问题了,在这点上我帮不了你。
嗯 好的,谢谢
0
Florian
Florian
哥们    你这个问题解决了吗,怎么解决的。现在我也遇到同样的问题了。我的sdk是4.3的,phoneGap是2.9.0    sdk换成4.2和2.3都不好使
返回顶部
顶部