apt-get -f install执行之后错误,python配置出错。。

coat 发布于 2014/01/29 16:38
阅读 3K+
收藏 0

有 15 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0 B 的额外空间。
正在设置 python2.7-minimal (2.7.6-5) ...
# Empty sitecustomize.py to avoid a dangling symlink
dpkg-query: error: --listfiles needs a valid package name but 'libpython2.7-minimal' is not: ambiguous package name 'libpython2.7-minimal' with more than one installed instance

使用 --help 查看关于查询软件包的帮助。
dpkg: error processing package python2.7-minimal (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 1
dpkg: dependency problems prevent configuration of python-minimal:
python-minimal 依赖于 python2.7-minimal (>= 2.7.5-1~);然而:
软件包 python2.7-minimal 尚未配置。

dpkg: error processing package python-minimal (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python2.7:
python2.7 依赖于 python2.7-minimal (= 2.7.6-5);然而:
软件包 python2.7-minimal 尚未配置。

dpkg: error processing package python2.7 (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python:
python 依赖于 python2.7 (>= 2.7.5-1~);然而:
软件包 python2.7 尚未配置。
python 依赖于 python-minimal (= 2.7.5-5);然而:
软件包 python-minimal 尚未配置。

dpkg: error processing package python (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python-gi:
python-gi 依赖于 python (>= 2.7);然而:
软件包 python 尚未配置。
python-gi 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。

dpkg: error processing package python-gi (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python-apt:
python-apt 依赖于 python (>= 2.7);然而:
软件包 python 尚未配置。
python-apt 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。

dpkg: error processing package python-apt (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of gconf2:
gconf2 依赖于 python;然而:
软件包 python 尚未配置。

dpkg: error processing package gconf2 (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python-six:
python-six 依赖于 python (>= 2.7);然而:
软件包 python 尚未配置。
python-six 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。

dpkg: error processing package python-six (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python-chardet:
python-chardet 依赖于 python2.6 | python2.7;然而:
未安装软件包 python2.6。
软件包 python2.7 尚未配置。
python-chardet 依赖于 python (>= 2.6.6-7~);然而:
软件包 python 尚未配置。
python-chardet 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。

dpkg: error processing package python-chardet (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of python-debian:
python-debian 依赖于 python (>= 2.6.6-7~);然而:
软件包 python 尚未配置。
python-debian 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。
python-debian 依赖于 python-six;然而:
软件包 python-six 尚未配置。
python-debian 依赖于 python-chardet;然而:
软件包 python-chardet 尚未配置。

dpkg: error processing package python-debian (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of gdebi-core:
gdebi-core 依赖于 python:any (>= 2.6.6-7~);然而:
软件包 python 尚未配置。
gdebi-core 依赖于 python-apt (>= 0.7.97);然而:
软件包 python-apt 尚未配置。
gdebi-core 依赖于 python-debian (>= 0.1.15);然而:
软件包 python-debian 尚未配置。

dpkg: error processing package gdebi-core (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of libgksu2-0:
libgksu2-0 依赖于 gconf2 (>= 2.28.1-2);然而:
软件包 gconf2 尚未配置。

dpkg: error processing package libgksu2-0 (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of gksu:
gksu 依赖于 libgksu2-0 (>= 2.0.8);然而:
软件包 libgksu2-0 尚未配置。

dpkg: error processing package gksu (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of gdebi:
gdebi 依赖于 python:any (>= 2.6.6-7~);然而:
软件包 python 尚未配置。
gdebi 依赖于 gdebi-core (= 0.9.3);然而:
软件包 gdebi-core 尚未配置。
gdebi 依赖于 python-gi;然而:
软件包 python-gi 尚未配置。
gdebi 依赖于 gksu;然而:
软件包 gksu 尚未配置。

dpkg: error processing package gdebi (--configure):
依赖关系问题 - 仍未被配置
dpkg: dependency problems prevent configuration of lsb-release:
lsb-release 依赖于 python (>= 2.7);然而:
软件包 python 尚未配置。
lsb-release 依赖于 python (<< 2.8);然而:
软件包 python 尚未配置。

dpkg: error processing package lsb-release (--configure):
依赖关系问题 - 仍未被配置
在处理时有错误发生:
python2.7-minimal
python-minimal
python2.7
python
python-gi
python-apt
gconf2
python-six
python-chardet
python-debian
gdebi-core
libgksu2-0
gksu
gdebi
lsb-release
E: Sub-process /usr/bin/dpkg returned an error code (1)



加载中
1
coat
coat

我用以下办法解决了,但不知道原因,,,望知情人士告之,感激不尽。。


cd /var/lib/dpkg  
sudo mv info info.bak  
sudo mkdir info



冰枫火灵X
冰枫火灵X
万分感谢!我的系统差点都只能重装了,用你的方法一下子就成功了。
1
coat
coat
还有。。吐鄛下。。。用百度搜这答案来的方便多了,但一直习惯google,结果问题只能来这里问了
1
笨鸟不想飞
笨鸟不想飞

引用来自“coat”的评论

我用以下办法解决了,但不知道原因,,,望知情人士告之,感激不尽。。


cd /var/lib/dpkg  
sudo mv info info.bak  
sudo mkdir info



我用你的方法没成功,但是我又把目录下的 status 删除了,重新 touch 了一个,解决了问题。

0
R-Lu
R-Lu

我感觉这个只能一时解决问题吧。

我记得dpkg有一个修复命令蛮有用的。

http://my.oschina.net/robinsonlu/blog/185966

这个就是我的解决方案,仅供参考哦。

0
coat
coat

引用来自“Robinson_lu”的答案

我感觉这个只能一时解决问题吧。

我记得dpkg有一个修复命令蛮有用的。

http://my.oschina.net/robinsonlu/blog/185966

这个就是我的解决方案,仅供参考哦。

到现在一直都行。。。,不过我会把这个记下的。
0
h
hartnett

攒,我按上面的方法成功解决

返回顶部
顶部