debian下gem install pry 出现错误,唉,资料真少

coat 发布于 2013/12/09 16:18
阅读 436
收藏 0
root@Blue:/home/coat# gem install pry
ERROR:  Could not find a valid gem 'pry' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)


至于为什么在root下,唉,当初安装rvm手误了。





加载中
0
coat
coat

引用来自“sevk”的答案

root 下面也可以吧,把 普通用户的 .rvm ln -s 过来,然后 bashrc 里面rvm相关的内容也复制过来

是的,我也觉得可以的!后来查了,是login-shell和non-login-shell的问题!


sevk
sevk
嗯,加个参数也行, 比如 bash --login
0
sevk
sevk
root 下面也可以吧,把 普通用户的 .rvm ln -s 过来,然后 bashrc 里面rvm相关的内容也复制过来
0
sevk
sevk

你这个错误是网络问题,提示找不到 pry 这个gem .

看这里 http://ruby.taobao.org 换源。 

返回顶部
顶部