svn1.6.17编译安装错误

Jceee 发布于 2015/05/03 23:17
阅读 1K+
收藏 0
SVN

环境:ubuntu 12

将subversion-1.6.17.tar.gz 和 subversion-deps-1.6.17.tar.gz

解压在同一个文件后,./configure 通过。

make出现错误:

../../subversion/libsvn_subr/libsvn_subr-1.la /opt/unzipDir/subversion-1.6.17/apr-util/libaprutil-1.la     -lexpat /opt/unzipDir/subversion-1.6.17/apr/libapr-1.la -lrt -lcrypt  -lpthread -ldl /opt/unzipDir/subversion-1.6.17/neon/src/libneon.la
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_release_name'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_display_status'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_import_name'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `GSS_C_NT_HOSTBASED_SERVICE'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_release_buffer'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_delete_sec_context'
/opt/unzipDir/subversion-1.6.17/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so: undefined reference to `gss_init_sec_context'
collect2: ld returned 1 exit status
make: *** [subversion/svn/svn] 错误 1


大部分都是gss相关的,这种类型的错误是引用包的路径出错还是缺少什么包?

加载中
0
Force武装卫队
Force武装卫队

缺少包 gss API 库,你应当安装,不过呢你的svn太老了 。

Force武装卫队
Force武装卫队
回复 @Jceee : libgssapi
Jceee
Jceee
版本老没办法,目标代码仓库的svn版本就是这个。gss api库是怎么装的?网上找不到相关的资料...
返回顶部
顶部