ubuntu 12.04 改了 Mysql 的 数据 目录 ,启动不了mysql,改回原来的就可以启动了

南无阿弥陀佛啊 发布于 2013/06/01 15:47
阅读 554
收藏 0

遇到了很奇怪的问题 ,在ubuntu 12.04下 想 改变Mysql 的 数据目录 ,原来在 var/lib/mysql 

改了 Mysql 的 数据 目录后 ,包括 my.cnf , apparmor.d/目录下的 usr.sbin.mysqld ,启动不了mysql,改回原来的就可以启动了.

改完 配置 文件 后 ,重新加载 apparmor ,提示 了 一句 

Skipping profile     apparmor.d/disable: usr.sbin.rsyslogd .


在网上搜了很多 都没有 找到 答案 。。。郁闷啊

加载中
0
gary34
gary34

这是因为ubuntu的安全设置问题。

sudo vi /etc/apparmor.d/usr.sbin.mysqld 
#把 mysql的数据存储目录改成你要放的目录

sudo /etc/init.d/apparmor reload

sudo /etc/init.d/mysql restart

0
南无阿弥陀佛啊
南无阿弥陀佛啊

这边 已经 改过 usr.sbin.mysqld 了 ,就是 启动不了 Mysql .参照网上 的 方法 做 的: 

1 改My.cnf  

2 改usr.sbin.mysqld

3 重新加载 apparmor

4 重启mysql  


这几步都做了,最后 就是 重启不了 mysql ,貌似 我 的 情况 比较 特殊 啊 。。服务器是阿里云的 



返回顶部
顶部