Ueditor nginx X-Frame-Options deny

魔神翼 发布于 2016/09/17 22:25
阅读 1K+
收藏 0

我在nginx添加了配置:

add_header X-Frame-Options "SAMEORIGIN";

普通加载网页没有问题, header是X-Frame-Options: SAMEORIGIN

但是使用UEditor的时候,出现错误:Refused to display '*/ueditor/dialogs/image/image.html' in a frame because it set 'X-Frame-Options' to 'deny'. 

查看发现header变了,X-Frame-Options: deny

始终无法加载UEditor的图片上次功能。

怎么才能设置成SAMEORIGIN呢?

	

nginx部分配置

server {

listen 443 ssl http2;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

ssl_prefer_server_ciphers on;

add_header Strict-Transport-Security max-age=15768000;
add_header X-Content-Type-Options nosniff;
add_header X-Frame-Options deny;
add_header X-XSS-Protection '1; mode=block';

nginx version: nginx/1.11.3

OS:    Ubuntu 14.04.5 LTS


加载中
返回顶部
顶部