Debian7 多架构软件包安装的问题

yymxddy 发布于 2013/06/14 16:00
阅读 1K+
收藏 0

如果,我装了64位的Debian7,看网上说支持多架构,以为今后再也不用装ia32-libs了。

就添加了架构 dpkg --add-architecture i386。

然后装开始装32位的包包,装的过程中,除了一些依赖之外,没有报什么错。

但是更多的情况是不声不响地就装完了,但是却无法运行。

我试装了wps-a10、foxit-reader、wineqq,这些软件都只有32位的。以前在Ubuntu上装的时候都要装ia32-libs。这回倒是能直接装上了,但是不声不响地装完了,却无法运行。用终端执行一看,还是少一些库。

例如,装完运行foxit-reader时是这各情况:

FoxitReader: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

怎么会这样呢?

加载中
0
开源中国餐饮部副厨师长
开源中国餐饮部副厨师长
貌似你自已已经回答了
yymxddy
yymxddy
但是不知道应该下载装哪个包才对
0
Sake
Sake
apt-file找找是在哪个包里面?
Sake
Sake
回复 @yymxddy : 不是啊,先用apt-file搜索是在哪个包里面。然后安装相应软件包。
yymxddy
yymxddy
直接这样apt-libgtk-x11-2.0.so.0? 谢谢!
返回顶部
顶部