druid强制依赖slf4j么?怎么启动都出错了

伪猫 发布于 2013/05/17 22:18
阅读 821
收藏 0
spring报数据源创建失败
加载中
0
wenshao
wenshao

问题的原因是druid-0.2.18接受了这个patch(https://github.com/alibaba/druid/pull/331)支持slf4j导致的。这个patch没有处理好存在slf4j-api而不存在相应的impl时的错误。

临时解决方案:引入slf4j-api的同时引入slf4j-jdk

0
0
伪猫
伪猫

引用来自“wenshao”的答案

druid-0.2.20已经解决这个问题: http://repo1.maven.org/maven2/com/alibaba/druid/
温少太热心啦 druid越用好用啊
返回顶部
顶部