关于python的'版本选取+开发工具+扩展'的问题

gaocheng 发布于 2010/12/18 01:14
阅读 460
收藏 1

我接触了python一段时间,感觉这个语言本身非常规整,但在扩展和开发上太乱了

用老版本的,有些新的特性不能用;用新版本,很多扩展库又不能用。{之前看到了一个推荐时用2.6}

还有就是开发工具,我主要用python做一些小游戏自娱自乐,却在开发工具和扩展包上转来转去的

我想问,大家能不能给我推荐一个python的“版本+开发工具+扩展”的组合。

或者大家谈谈自己都用哪个组合?

谢谢各位,

加载中
0
四哥
四哥
2.5的库应该是最多的。
0
黄金乞丐
黄金乞丐

本人用的是2.5的,具体点算是2.5.1, 因为我发现目前好多扩展库支持的较为全面的就是2.5版本的。

有次装了2.6的。结果几个常用的库就安装不了,就退到2.5了。

开发工具:因为主要是windows平台,所以用的是eclipse3.4 + pydev1.6.2,如果不想自己安装pydev插件,就搜一下easyEclipse,它有专门的集成版本,如支持python开发的版本,支持PHP开发的专门版本。

0
sam_ai
sam_ai

我用2.5。

不但因为2.5的库最多,而且因为2.5比较中规中矩。

2.6、2.7库少不说,其实就是2.5的加强,么意义。

3.x的太激进,有点吓人。
python的那个号现在其实已经不是版本问题了,而是分支了,就像方言一样。

0
返回顶部
顶部