怎样修改kvm虚拟机的mac地址?

jack_jones 发布于 2014/07/03 11:08
阅读 1K+
收藏 0

@三木-Hacker 你好,想跟你请教个问题:


我用qemu-systemx86_64命令

我需要两台虚机,创建一个(a),复制一个(b)

启动后,两台机器mac及ip都一样,都能ping通外网

我需要改其中一台的mac及ip,要怎么更改?

我用过参数-net nic,macaddr=f9:c0:9e:6d:b2:2e,但是虚机网卡起不来

ifup eth0提示:device eth0 does not seem to be present, delaying initialization

怎么办?

加载中
0
王明明
王明明
修改下kvm的配置文件时的mac地址试试
王明明
王明明
回复 @jack_jones : 我用 virt-install 创建的虚拟机,配置文件在/etc/libvirt/qemu/**.xml ,qemu-img没用过,你看看这个路径有没有配置文件
jack_jones
jack_jones
没有配置文件,只是用了qemu-img创建了镜像文件,然后用qeme-system-x86_64启动了,没别的文件
0
l
l_gang
在图形界面把另外网卡的mac copy到你需要的网卡,然后service network restart 即可。
jack_jones
jack_jones
没有图形界面,都是通过qemu-system-x86_64执行的
0
宅蓝三木
宅蓝三木
看看你的ifconfig输出的信息是什么?
jack_jones
jack_jones
ifconfig,只有一个lo
0
宅蓝三木
宅蓝三木
你的mac地址不正确,mac地址的从前面数第2位必须是偶数,否则表示组播地址。把f9换成f0应该没有问题了。
jack_jones
jack_jones
在虚机里,删除/etc/udev/rules.d/70-persistent-net.rules文件,重启就好了,以后每次换mac,都要删除这个文件吗,太麻烦了
0
jack_jones
jack_jones

引用来自“三木-Hacker”的评论

你的mac地址不正确,mac地址的从前面数第2位必须是偶数,否则表示组播地址。把f9换成f0应该没有问题了。
这是我的参数      
qemu-system-x86_64 -name centos2 -drive file=centos_hda.img,if=virtio,bus=0,unit=0,boot=on -drive file=centos_hdb.img,if=virtio,bus=0,unit=1,boot=on -enable-kvm -cpu host -smp 2,sockets=2,cores=2,threads=2 -m 1024 -mem-path /dev/hugepages -balloon virtio -net nic,macaddr=54:52:d5:ab:83:10,model=virtio -net tap,ifname=tap2,vnet_hdr=on,vhost=on,script=/etc/qemu-ifup,downscript=no -usb -vnc :2 -usb -usbdevice tablet -daemonize && vncviewer :2        
mac地址已经换了,还是不行阿
0
宅蓝三木
宅蓝三木
使用用户模式的网络i试试吧,-net user 替换掉-net tap。我怀疑你的桥接模式i配置的有问题。
jack_jones
jack_jones
我在虚机里删除/etc/udev/rules.d/70-persistent-net.rules文件就好了
返回顶部
顶部