maven3.25 jdk1.6

灯光下的宁静 发布于 2016/06/13 19:33
阅读 700
收藏 0
maven的安装,我使用maven3.2.5 ,官方文档上说的是3.2.5及以前的版本要求jdk1.6就可以了,但是我装了jdk1.6和maven3.2.5  3.0.3  3.0.4 都不行,执行mvn -version 就报错如下:
java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor version 51.0
我明白这个错的意思但是我完全按照要求写的为什么还是  3.2.5和之前的版本还是要求jdk1.7呢

加载中
0
阿信sxq
阿信sxq

我刚才去查看了下我的maven3.2.5,这个类的版本是

cafe babe 0000 0032



换算出来就是50.0,不应该是51.0,所以有可能是你安装的maven有问题哈,我是下载的官方给的二进制包


0
LarrySu
LarrySu
检查一下你的JAVA_HOME设置
0
阿信sxq
阿信sxq
有可能是你装了1.6,但是还有1.5的在,你执行下  java -version   看看版本呢
0
沧海_Sea
沧海_Sea
直接用1.8 就OK了
返回顶部
顶部