python3下supervisor-py3k的安装, 或其代替品

Tyler_Temp 发布于 2014/09/15 13:10
阅读 6K+
收藏 0

supervisor目前还没有正式出python3的支持

目前唯一支持的是:[supervisor-pyk3](https://github.com/palmkevin/supervisor-py3k)

不过上面没写怎么安装, setup.py也没提供对py3k的支持

我试了一下将supervisor放到python3的lib库中, 配置好后运行

```

supervisord -c supervisord.conf

supervisorctl start all```

还是无法运行: 

```

pyenv: supervisorctl: command not found


The `supervisorctl' command exists in these Python versions:
  2.7.8

```

貌似这个supervisor-py3k没安装成功?


当然换回py2是一个方法. 但我依然想知道py3k下的解决方法: supervisor-pyk3如何安装? 或py3k下有什么替代品么

(我在建网站: tornado+supervisor+nginx)

加载中
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部