求助红薯,Nginx代理对文件系统的权限问题

Zee 发布于 2011/04/25 16:45
阅读 557
收藏 1

因为Nginx无法实现SVN的整合,所以Svn配置就成了Apache+ Subversion ,具体配置见http://www.oschina.net/bbs/thread/18976

然后用Nginx代理到Apache访问Svn

配置如下:

 server {
        listen       80;
        server_name localhost www.xxxx.net;

        #charset koi8-r;

        #access_log  logs/host.access.log  main;      

        # SVN访问URLwww.xxxx.net/svn 代理到Apache

        location /svn {                    
           proxy_pass http://localhost:99/svn;    
        }     
        #Tomcat网站的主要程序域名的首页
        location / {         
           proxy_pass http://localhost:8080;
           include proxy.conf;
        }

 经过以上配置:检出项目 www.xxxx.net/svn/project1

   SVN访问检出都正常,但是不能提交更新!提示 forbidden 应该是权限问题,

于是我用www.xxxx.net:99/svn/project1 跳过nginx代理直接访问,确能正常检出,也能正常提交更新!

问题肯定出在nginx代理过去时权限问题上,但是不知道该怎么处理,

红署哥,帮帮忙! 帮我看看该怎么配置!才能像这样 www.xxxx.net/svn/project1 正常检出和提交更新呢?

加载中
0
用户已屏蔽
用户已屏蔽

哦,求红薯,还好不是我  路过..

0
Zee
Zee

红薯,代指高手的意思!代指能解决问题的所有同任们!

0
红薯
红薯

红薯不能代表能解决问题的同仁们。

红薯不会哦

0
高东
高东

把红薯做成粉

0
北京java
北京java

看下你提交更新的时候使用svn:// 提交的还是http://

0
北京java
北京java

还有最后加个斜线试试吧http://localhost:99/svn/,以前遇到过这样的问题,不过环境不一样,你可以试试。

0
Zee
Zee

引用来自#6楼“北京java”的帖子

看下你提交更新的时候使用svn:// 提交的还是http://

 是http:// 提交

0
hongshenghe
hongshenghe

贴下相信你的错误信息,没有错误信息大家只能猜了

0
于忠达
于忠达

引用来自#5楼“高东”的帖子

把红薯做成粉

红薯粉好多哦,还要再做吗?

0
Zee
Zee

错识提示:

Commit

C:\Documents and Settings\Administrator\桌面\test\branches\新建 文本文档.txt

C:\Documents and Settings\Administrator\桌面\test\新建 BMP 图像.bmp

C:\Documents and Settings\Administrator\桌面\test\新建 BMP 图像.bmp

Commit failed (details follow):

access to 

'/svn/test/!svn/wrk/20745fc1-292b-fe49-991c-1d01773f1616/%E6%96%B0%E5%BB%BA%20BMP%20%E5%9B%BE%E5%83%8F.bmp' 

forbidden

韦仕达
韦仕达
请问这个问题解决了吗? 求解
返回顶部
顶部