java中,使用高版本的特性,怎么在不改源码的情况下兼容低版本

import_key 发布于 2016/02/05 17:21
阅读 274
收藏 0

我使用jre1.8 中流的特性,jre 1.7 中类型擦除的特性。

怎么在便改变源码的情况下,能够兼容jre1.5 或 jre 1.6


以上问题是源于公司的产品是在jre 1.7的环境下开发的,使用呢一些新的特性,但是有些客户的使用环境是jre1.5 或 jre 1.6。

哪问题来了:


try{
    // 1 我就想问有什么办法能够使用Java新版本新特性的情况下,能够屏蔽转换为低版本的差异性。
}finally{
    // 2 各位大哥,平时你们公司遇到此问题,什么好解决方案或建议
}




加载中
0
Feng_Yu
Feng_Yu
打包个docker给客户算了
Feng_Yu
Feng_Yu
回复 @import_key : 当然能。docker这么火爆就是因为这个——可以将依赖环境进行打包隔离
import_key
import_key
docker不了解,docker 能解决jdk版本的问题吗?
返回顶部
顶部