emacs无法调用配置文件的问题

canzyq 发布于 2012/08/10 01:10
阅读 577
收藏 0

我在centos6.3 中编译安装了emacs 23.4,安装完成以后在~/目录下创建了.emacs配置文件,写完配置发现运行的emacs还是没有调用配置。请问高手这是为何?难道emacs的配置文件路径改了?

配置文件我随便粘的。如下:

(setq default-major-mode 'text-mode);一打开就起用 text 模式。
(global-font-lock-mode t);语法高亮
(auto-image-file-mode t);打开图片显示功能
(fset 'yes-or-no-p 'y-or-n-p);以 y/n代表 yes/no,可能你觉得不需要,呵呵。
(column-number-mode t);显示列号
(show-paren-mode t);显示括号匹配
(display-time-mode 1);显示时间,格式如下
(setq display-time-24hr-format t)
(setq display-time-day-and-date t)
(tool-bar-mode nil);去掉那个大大的工具栏
(scroll-bar-mode nil);去掉滚动条,因为可以使用鼠标滚轮了 ^_^
(mouse-avoidance-mode 'animate);光标靠近鼠标指针时,让鼠标指针自动让开,别挡住视线。很好玩阿,这个功能
(setq mouse-yank-at-point t);支持中键粘贴
(transient-mark-mode t);这个忘了,郁闷!
(setq x-select-enable-clipboard t);支持emacs和外部程序的粘贴
(setq frame-title-format "zhan@%b");在标题栏提示你目前在什么位置。你要把zhan改成自己的用户名
(setq default-fill-column 80);默认显示 80列就换行

加载中
0
姚先津
姚先津
看看你的/root目录下的.emacs文件吧.
0
canzyq
canzyq
我的root下面没有.emacs文件,我创建了一个,还是没有调用
姚先津
姚先津
然后再用root身份启动emacs
0
河边洗澡
河边洗澡
 貌似如果配置文件里有错误,就不会显示的
返回顶部
顶部