tengine 已经几年没人维护了,osc为什么还要用?

linapex 发布于 2016/10/03 00:09
阅读 1K+
收藏 2

知道osc用的是,tengine

所以去了解了 tengine,但发现tengine 支持的 nginx 的版本才1.6.x。

而实际的nginx版本,已经 1.11.x了,更新了很多,再然后去

https://github.com/alibaba/tengine

看了,发现确实几年没更新了,还是算了,系统用nginx就好了,淘宝的这个不敢用。

加载中
3
开源中国最大五毛
开源中国最大五毛

看来并不能活在一个维度。

Latest commit b15de76 on 24 Aug


src be consistency with @dinic 's patch a month ago

1
eechen
eechen
Tengine是Nginx分支,不跟进Nginx版本,一个月前就有代码更新,怎么说是几年前呢?
春哥的OpenResty则跟进Nginx版本,集成Lua Web相关支持模块.
0
linapex
linapex

引用来自“大舒”的评论

看来并不能活在一个维度。

Latest commit b15de76 on 24 Aug


src be consistency with @dinic 's patch a month ago

http://tengine.taobao.org/changelog_cn.html#2_1_2


官方是15年12月31日,主要是担心,tengine 用的nginx 1.6.x的版本为核心,现在一些新的功能与bug没法使用了。

0
linapex
linapex

引用来自“eechen”的评论

Tengine是Nginx分支,不跟进Nginx版本,一个月前就有代码更新,怎么说是几年前呢?
春哥的OpenResty则跟进Nginx版本,集成Lua Web相关支持模块.

分支也有基于核心版啊,1.6.x 与 1.11.x 版本差距是不是比较大。


是啊,代码更新,我看了,看错了,看成文件最后修改时间了。。 git 确实是 8月份才更新。

0
开源中国最大五毛
开源中国最大五毛

引用来自“大舒”的评论

看来并不能活在一个维度。

Latest commit b15de76 on 24 Aug


src be consistency with @dinic 's patch a month ago

引用来自“linapex”的评论

http://tengine.taobao.org/changelog_cn.html#2_1_2


官方是15年12月31日,主要是担心,tengine 用的nginx 1.6.x的版本为核心,现在一些新的功能与bug没法使用了。

你要的是openresty

0
南湖船老大
南湖船老大

可是,你能说出 1.6.x 和 1.11.x 的区别吗?

对于 99%的网站来说,nginx 1.0 和 nginx 1.11 没任何区别,我4年前的nginx配置文件拿到最新版一样能用,而且也没任何变化。

我记得4年来,对99%的网站来说,nginx 增加的两个可能会用到的变化就是1.4 的worker的auto绑定,还有1.9的 reuseport。

0
LongRaindy
LongRaindy
我们项目上还用着linux自带的1.4.6版本的nginx呢,你说为什么呢,因为足够稳定,性能也与最新版本相差不大,配置也100%兼容,把折腾都发挥到需要折腾的地方去吧。
0
贝克街小分队
贝克街小分队

貌似nginx这玩意时不时也会抖出几个漏洞吧? 楼上说什么肉眼看不出什么区别,你们到底写代码还是当美工,怎么还停留在简单看看有没有什么新功能之类。就好像在菜市场买菜一样。

虽然某些国产知名大厂节操完全就是负的,完全就不敢更新。他妈的升级后还能把优秀功能阉割掉。凸(゚皿゚メ)

-1
钛元素
钛元素

我发现c或者c++特有用,尤其是在看这些东东的源代码的时候。

妈蛋!被人影响了,现在只会高级语言,对底层了解不够

刘大神
刘大神
c和c++不是高级语言?
-1
钛元素
钛元素

引用来自“eechen”的评论

Tengine是Nginx分支,不跟进Nginx版本,一个月前就有代码更新,怎么说是几年前呢?
春哥的OpenResty则跟进Nginx版本,集成Lua Web相关支持模块.

毫妙巅峰显文章

文章舒展亦如春


返回顶部
顶部